Can't install gt package

Hi people,

I have on several occasions tried to install the gt package, but I always get an error.

Any help with how I should proceed is most welcome.

Thank you

Downloading GitHub repo rstudio/gt@master
Downloading GitHub repo rstudio/sass@master
trying URL ''
Content type 'application/x-msdownload' length 108622512 bytes (103.6 MB)
downloaded 103.6 MB

Error: Could not find tools necessary to compile a package
> sessionInfo()
R version 3.5.3 (2019-03-11)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

[1] LC_COLLATE=Danish_Denmark.1252  LC_CTYPE=Danish_Denmark.1252    LC_MONETARY=Danish_Denmark.1252 LC_NUMERIC=C                    LC_TIME=Danish_Denmark.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
 [1] processx_3.3.0    compiler_3.5.3    magrittr_1.5      assertthat_0.2.1  R6_2.4.0          cli_1.1.0         prettyunits_1.0.2 tools_3.5.3       rstudioapi_0.10  
[10] curl_3.3          yaml_2.2.0        crayon_1.3.4      remotes_2.0.2     callr_3.2.0       ps_1.3.0          pkgbuild_1.0.3

For compiling packages under windows OS you need to install Rtools

1 Like

Thank you!

That got me a bit further, but now I get another error message that I don't understand.

Downloading GitHub repo rstudio/gt@master
Downloading GitHub repo rstudio/sass@master
√  checking for file 'C:\Users\sharsted\AppData\Local\Temp\RtmpA1kSJP\remotes4c886a1d16b8\rstudio-sass-d90395e/DESCRIPTION' ...
-  preparing 'sass': (1.3s)
√  checking DESCRIPTION meta-information ... 
-  cleaning src
-  checking for LF line-endings in source and make files and shell scripts (752ms)
-  checking for empty or unneeded directories (736ms)
   Removed empty directory 'sass/scripts'
-  building 'sass_0.1.0.9000.tar.gz'
Installing package into β€˜C:/Users/sharsted/Documents/R/win-library/3.5’
(as β€˜lib’ is unspecified)
* installing *source* package 'sass' ...
** libs

*** arch - i386
C:/PROGRA~1/R/R-35~1.3/share/make/ warning: overriding recipe for target 'shlib-clean' warning: ignoring old recipe for target 'shlib-clean'
c:/Rtools/mingw_32/bin/gcc  -I"C:/PROGRA~1/R/R-35~1.3/include" -DNDEBUG -I./libsass/include         -O3 -Wall  -std=gnu99 -mtune=generic -c compile.c -o compile.o
sh: c:/Rtools/mingw_32/bin/gcc: No such file or directory
make: *** [C:/PROGRA~1/R/R-35~1.3/etc/i386/Makeconf:208: compile.o] Error 127
ERROR: compilation failed for package 'sass'
* removing 'C:/Users/sharsted/Documents/R/win-library/3.5/sass'
Error in i.p(...) : 
  (converted from warning) installation of package β€˜C:/Users/sharsted/AppData/Local/Temp/RtmpA1kSJP/file4c88550153ae/sass_0.1.0.9000.tar.gz’ had non-zero exit status

My organisation has a very strict security policy, so I reinstalled Rtools35, and set Rstudio to administrator rights. That solved the problem.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.