Can't install or update packages

Hi everyone,

I am not able to install or update any packages in R studio version 1.1.383. I am on macOS Mojave. This is the error message I get when I try to download or update any packages.

Warning in strptime(xx, f <- "%Y-%m-%d %H:%M:%OS", tz = tz) :
unknown timezone 'zone/tz/2019c.1.0/zoneinfo/America/Montreal'

  • installing source package ‘cansim’ ...
    ** package ‘cansim’ successfully unpacked and MD5 sums checked
    ** R
    ** data
    *** moving datasets to lazyload DB
    ** inst
    ** preparing package for lazy loading
    Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
    namespace ‘Rcpp’ 0.12.13 is being loaded, but >= 1.0.0 is required
    ERROR: lazy loading failed for package ‘cansim’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.4/Resources/library/cansim’
    Warning in install.packages :
    installation of package ‘cansim’ had non-zero exit status

I would try to install first package Rcpp because you have an error
namespace ‘Rcpp’ 0.12.13 is being loaded, but >= 1.0.0 is required

If this does not work (what is probable if you can't install any package) I can not help you further because I am not familiar with your operating system.

I see that your version of RStudio is not very current. Is it possible to update to a newer version?
For anyone advising you it would also be interesting to know your version of R.

Yeah. You should probably update your R and Rstudio.

Hi,

Thank you for you responses.

I just updated RStudio and R and I have the exact same error message.

I don't know what to do ...

Thank you everyone, it is solved!

R was not installed, just RStudio was

I feel dumb

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

What happens when you try to update Rcpp? Do you get any error message?

install.packages("Rcpp")