Could not create new project in RStudio

RStudio: 2022.07.1
OS: Windows 10 Education

Something has go wrong with my RStudio installation.

The problem I will discuss here is creating a New Project.

Steps Taken:

  1. Start RStudio
  2. Click File -> New Project

the following error occur
(TypeError) : Cannot read property 'python' of null

I tried the solutions found on the internet by copy the findstr.exe file from C:\Windows\System32 to C:\Program Files\RStudio\bin but the problem still persist.

Sorry to hear you're having trouble! We have a candidate fix for this in our daily builds if you'd like to try it:

You want build 2022.11.0+141 or higher. More info: Cannot create project: (TypeError): Cannot read property 'python' of null · Issue #11769 · rstudio/rstudio · GitHub

1 Like

Thanks, I was experiencing the same problem and after installing the daily build it works!

Hi Jonathan,

Thanks for your swift response. Build 2022.11.0+141 works for my case. The problem is no longer persist.

Hi Jonathan,

Build 2022.11.0+141 solved the new project problem. But currently the shell option under tools is missing.
I'm not sure whether it's related to the version or not.
Is there any plan to launch the official version soon?

Tools/Shell has been deprecated (it predates the Terminal tab). You can read more here: Implement (or deprecate) Tools / Shell for Electron · Issue #11253 · rstudio/rstudio · GitHub

The official version will be launched in November, hence the 2022.11 version number. Hope that helps!

1 Like

I follow your link to read but not sure whether I understand correctly.
Does it mean that "terminal" can be used as replacement of "Tools/Shell"?

Yup. You can read about how to use the Terminal here:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.