Dark themes not working properly with "modern" and "sky" (Rstudio themes) on my computer

Hey guys, i will admit to not being the best at computers so there might be an obvious reason for this that i am just missing... I hope someone will help me anyhow! :smiley:
As the title says i have a visual problem with my Rstudio and it really makes it much more enjoyable for my eyes to have a completely dark Rstudio.

Description of problem:
Firstly the problem is that across all themes (Rstudio theme and Editor theme) i have a vertical line in the source pane (see picture below). This is not important for me to fix but might give a clue as to what the problem is.
Secondly when i use dark Editor themes ("kr theme" in this instance but it does the same on all dark themes) on "modern" or "sky" Rstudio Themes then the cross section does not become dark and also the bottom right quadrant/pane has a weird text colour that is basically unreadable.

Using kr theme, modern:

I cannot link a picture to how it normally looks (only one media item for new users) but a quick google search should suffice if memory doesn't.

The problem occured after i got a new computer (PC). I firstly installed Rstudio through anaconda (blasphemy i know) and when there were problems with downloading and loading packages i simply changed back to downloading it through official site.
The problem occured as i downloaded it through the official site.
through a plethora of google searches it seemed evident that the problem was related to files on the computer that hadn't been removed properly after uninstalling the anaconda.
I have thus attempted to:

  • use 3'rd party uninstallers,
  • Manually removing all related files,
  • Removing files in the "app data" folder (Rstudio folder under Roaming and Rstudio-desktop under Local),
  • Resetting PC to factory settings and simultaneously deleting all files on the pc.

Another facet which might be important to know is that i have followed the steps of this guide in order to fix unresponsive white screen during startup of Rstudio: During startup - Warning message: Setting LC_CTYPE= failed on Windows.
This means that i now have a Renviron file which modifies the startup of the program (from what i understand).

I hope someone can save my eyes from the cruel bright light! :smiley:

3 Likes

I second this. I have the same problem on a new windows computer.

This is the margin column. You can turn it off in Options -> Code -> Display -> uncheck Show Margin.

Thanks for the answer! :smiley:
I have since returned the computer for other reasons so i cannot check whether your suggestion works! I will however leave the post if others might find it useful!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.