Debug message on Shiny

I have begun receiving an error though whenever I try to run the my app from within the project. When I try to run it, my code is highlighted yellow and in the console it reads that I need to debug. I haven't changed the specific gt table at all, and it was working fine so I'm not sure whats going on...

If I open the app.r file directly, and not within my project, I am able to run it without an issue. I can even publish it. But when I do so within the .rproj this note pops up and my app doesn't include any graphs.

Any help would be hugely appreciated!

Called from: eval(expr, p)
Browse[1]> n
debug at /Users/John/Desktop/GOV/prep_cost_effectiveness/app.R#577: output$table2 <- render_gt({
    filtered4 <- hiv_aids_all %>% filter(race_ethnicity == input$race2Input, 
        transmission_category == "Male-to-male sexual contact")
    filtered4 %>% group_by(year) %>% summarize(total_cases = sum(cases)) %>% 
        mutate(direct_costs = total_cases * 259997.01, indirect_costs = total_cases * 
            1089414.34, total_costs = direct_costs + indirect_costs) %>% 
        select(year, direct_costs, indirect_costs, total_costs) %>% 
        ungroup(year) %>% gt() %>% tab_header(title = "HIV Associated Costs by Year", 
        subtitle = "Prices are in 2020 USD") %>% cols_label(year = "Year", 
        direct_costs = "Direct Costs", indirect_costs = "Indirect Costs", 
        total_costs = "Total Costs") %>% data_color(2:4, "Reds") %>% 
        fmt_currency(., 2:4) %>% fmt_number(., 2:4, decimals = 0)
})
Browse[2]> 

In my console I'm given the option to continue to the next chunk. When I click this manually, I'm able to execute the entire app...

Is it possible that Shiny is stuck in a debugging mode and thinks it needs to consider this code chunk even though there's no error?

I'm new to all of this so forgive my ignorance :pray:

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

I suggest restarting your session with control shift r