Different current version of RStan in Windows 10 & Windows 11?

With today's update of RStan, I have found that on my home Windows 11 pc, the version gets updated to version 2.26.11, while on my University research desktop that runs on Windows 10 and on my Ubuntu desktop, the version gets updated to version 2.21.7. In all three cases, the Primary CRAN repository is set to "Global (CDN) - RStudio". So this isn't a repository lag issue. The only difference that I can find is that the Windows version is different. (As I noted, my home computers are running Windows 11 and Ubuntu 22.04.1 while my U research desktop is running Windows 10.)
My question, then, is there a separate version numbering system for the rstan version running on different OSs, or is there a real or meaningful difference between the 2.21.7 versions and the Windows 11 2.26.11 version?
Thanks for any explanation. Larry Hunsicker

Which version of R are you using on the different platforms?
AFAIK, the official rstan version on CRAN is 2.21.x, and that is what I have on my Xubuntu machines.
Under Windows, R changed its tool chain between R 4.1.x and 4.2.x, before 4.2.x R was distributed on Windows as 32bit and 64 bit, since 4.2.0 only as 64 bit and with another tool chain.
I had not realised the implication of that change before our semester started. To keep a long story short, I had to tell my student to (a) either use R 4.1.3, the tool chain for that version of R and install rstan from CRAN, or (b) if they wanted to use R 4.2.x to install the tool chain for that version of R and then follow the instructions that I found on some blog of the rstan community and which installed essentially rstan 2.26.x on their machine.
I only had access to Windows 10 machines, but, perhaps, there is some further difference between Windows 10 and Windows 11. If so, it would start to become scary for lecturers like me :smile:

On your last question, yes, there would be meaningful differences as Stan is evolving.
IIRC, based on reading the (latest) manual, I told my students that they can use alpha ~ standard_normal() (or was it std_normal()) in the model block to put a standard normal prior on the parameter alpha. Only to realise that that command exist in the version of Stan described in the newest manual but not in the version of Stan that is installed with rstan at the time.
There seem to be some other features that are described in the manual of Stan 2.26 (or later), that are not implemented in Stan 2.21.
Cheers, Berwin

Thanks, Berwin ;

The answer to your first question is that my R version is 4.2.1 for all three desktops, and, of course, I had to update my tool chain on all three desktops. The upgrade to R 4.2.0 caused havoc for other users of the U. research cluster, so they had to downgrade to R 4.1. But the sysop created a way for the users that wanted to upgrade to R 4.2 to do so, and I have been on 4.2.1 for a month or so.
However your question nudged me to remember another anomaly. My University desktop and my Ubuntu machine are both running RStudio version 2022.2.3, whereas my home Windows 11 machine is running RStudio version 2002.07.1. So, my Windows 11 machine is running a numerically "earlier" version than the U. remote desktop and the Ubuntu machine. I ignored this because I was not finding any problem using the earlier version of RStudio, and I mostly use my home Windows 11 machine for exploring new packages. When I check for RStudio updates, all three tell me that they are current. Again, there is something about "Global (CDN) - RStudio" that considers different versions of RStudio (and now rstan) to be "current" for different OSs.

With respect to your second post, I use rstan primarily via rstanarm and brms. (I'm not smart enough to use rstan directly. Maybe I should take your course!) All three desktops are running brms version 2.17.0 and rstanarm version 2.21.3. So, fortunately, it seems that both rstanarm and brms worked peacefully with the respective rstan versions that got updated this AM. I'll check that today with the updated versions of rstan.

But in general I think that for my production work I should be using the most updated version of software. (Except when it is a version like X.0, where I generally wait for the bugs in a new major upgrade get worked out.) So I'd like to be able to update my U. research desktop rstan to 2.26.11. Could you relocate the instructions that you "found on some blog of the rstan community and which installed essentially rstan 2.26.x on their machine"? I'd be very grateful for that. Thanks for your help. (I hope that "it [hasn't] started to become scary for lecturers like me." :smile:

And welcome to the RStudio site! Larry Hunsicker

1 Like

This might be the blog post referred to by @BAT

Yes, that is the one.
Cheers, Berwin