Double-click of RStudio-1.2.5033.dmg file produces no response at all


I'm running macOS v 10.15.2
I've downloaded R-3.6.2.pkg from the Oregon State CRAN site. Double-clicked and default installed that R package. I've successfully opened an R-console and run a few commands. When I type Sys.which("R") in the R Console it replies: "/usr/local/bin/R"

I'm now trying to download and install RStudio from what I assume is the official website through the open source link. I've chosen the DOWNLOAD RSTUDIO DESKTOP link on that page. It downloads to my download directory as seen through the apple finder app. When I double click on the RStudio-1.2.5033.dmg file absolutely nothing happens. No messages, nothing. I've run "md5 RStudio-1.2.5033.dmg" as I did with the R package and get what looks like a reasonable checksum although I don't know where to check that value for the RStudio md5. I've moved the 126.9MB RStudio-1.2.5033.dmg file to the applications directory where the appears to reside. I've tried deleting and reloading the RStudio dmg file. Double clicking that file produces no response of any kind.

Does anyone have any advice for what could be the problem?

Thank you for any help you can provide.

This problem was fixed after rebooting, downloading and installing macOS 10.15.3. I tested the double-click of the dmg as noted above before installing the macOS update this morning (including reboot first) and still no response at all. Performed the 10.15.3 update then double-clicked the RStudio-1.2.5033.dmg file as before except this time it immediately started the install and completed everything as, I assume, it should. I now have an RStudio window which looks like the other ones I've seen online.

Here are the two links to what this macOS update included:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.