dplyr not installing

Hi I cannot install dplyr on my computer, however I can install other packages. I have tried multiple times to delete and re-download the software and Rstudio but nothing will work. I have attached the error codes I get when I try. Thank you for any help.

Hi, and welcome!

It appears that you are on MAC OS and that the file you downloaded is a source file. Apple has a non-standard compiler that sometimes works and sometimes doesn't. Fortunately, Saint Simon Urbanek does the brain surgery needed to get it in shape and puts the ready-to-use binaries on CRAN.

So, my recommended solution is

install.package(dplyr, repo = https://cloud.r-project.org)

I am sorry but this did not work. I attached the error code again.
Screen Shot 2020-02-07 at 8.53.53 PM

Sorry, I was wrong!

There was a problem with CRAN central and the mirrors, including the one I sent, started reflecting it. Everything should be normal tomorrow. For the time being, I've confirmed that

 install.packages("dplyr", repo = 'https://mac.R-project.org')

is working.

Okay so I tried this, and at first it seemed to work, as the photo below shows, but then when I went to check dplyr in the packages tab and I got the red error code again. I am so sorry for all the problems I have been going to a lot of different people about this and nobody can seem to figure it out.

Don't see an attachment, but here's what I got

>  install.packages("dplyr", repo = 'https://mac.R-project.org')
Installing package into ‘/Users/rc/Library/R/3.6/library’
(as ‘lib’ is unspecified)
trying URL 'https://mac.R-project.org/bin/macosx/el-capitan/contrib/3.6/dplyr_0.8.4.tgz'
Content type 'application/x-gzip' length 6846395 bytes (6.5 MB)
downloaded 6.5 MB

The downloaded binary packages are in
> library(dplyr)

Attaching package: ‘dplyr’

The following object is masked from ‘package:MASS’:


The following objects are masked from ‘package:lubridate’:

    intersect, setdiff, union

The following objects are masked from ‘package:stats’:

    filter, lag

The following objects are masked from ‘package:base’:

    intersect, setdiff, setequal, union


Sorry I forgot to upload the image of the error code, here it is.

Sorry, but what you shared does not indicate that you typed what technocrat recommended you type.

install.packages("dplyr", repo = 'https://mac.R-project.org')
1 Like

Here is the full picture. So sorry about that.

Try without the lib.loc stuff


Does it matter is the dplyr box is checked on the right side?

It depends what you mean by "does it matter" - the check mark indicates that the package is "loaded", i.e., the package namespace is attached to the search path. I think that if you just do library(dplyr) as suggested by @nirgrahamuk then you should be good to go with dplyr.

The reason I ask is because using library(dplyr) or physically checking the box is what gives me the error code.

Now that you installed dplyr. And call it with a simple library () call. What is your error code?

Screen Shot 2020-02-09 at 11.48.35 AM

Here is the whole thing:

It seems like you have a corrupted installation of the Rcpp package, try reinstalling it, restart your R session and see if that solves the issue.

Can you tell me how to do this, I am sorry, I am new to R?



Another error code, I am beginning to think my computer is hopeless. Screen Shot 2020-02-09 at 1.19.05 PM