Error Installing tmap package

I tried installing the tmap package but received the following Error:

  There is a binary version available but the source version is later:
     binary source needs_compilation
tmap  2.3-1  2.3-2             FALSE

installing the source package ‘tmap’

trying URL ''
Content type 'application/x-gzip' length 2928091 bytes (2.8 MB)
downloaded 2.8 MB

* installing *source* package 'tmap' ...
** package 'tmap' successfully unpacked and MD5 sums checked
** using staged installation
** R
** data
** inst
** byte-compile and prepare package for lazy loading
ERROR: lazy loading failed for package 'tmap'
* removing 'C:/Users/Julian/Anaconda3/envs/rstudio/lib/R/library/tmap'
Warning in install.packages :
  installation of package ‘tmap’ had non-zero exit status

I tried updating all the packages in my library, and have just installed rgdal, rgeos and PROJ.

Thank you in advance for your help!

When using RStudio trough Anaconda you can't install packages with install.packages() you have to use the "Anaconda Navigator" to install them (and you are limited to the versions they have on their repositories).

I would recommend you to use a regular standalone installation of R and RStudio when working with R and leave Anaconda for your Python work.

I actually did use install.packages() in the console to install many other packs, it's just tmap (and later, raster) that could not be installed!

Anyways, I will try switching to standalone R and R Studio, thank you for the help!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.