Error loading blob package


Kind of new to R and trying to use the DBI and odbc packages. The odbc package requires the blob package but it's not loading (either on it's own or as part of tidyverse).

I notice that the release date for blob is yesterday but I don't know if this is an issue with this new version (I don't know how to find an older version).


Installing package into ‘D:/Users/Jon Biavati/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)

  There is a binary version available but the source version is
     binary source needs_compilation
blob  1.2.0  1.2.1             FALSE

installing the source package ‘blob’

trying URL ''
Content type 'application/x-gzip' length 10099 bytes
downloaded 10099 bytes

Warning: invalid package 'D:\Users\Jon'
Warning: invalid package 'Biavati\AppData\Local\Temp\4\RtmpCMMfgV/downloaded_packages/blob_1.2.1.tar.gz'
Error: ERROR: no packages specified
Warning in install.packages :
  installation of package ‘blob’ had non-zero exit status

The downloaded source packages are in
	‘D:\Users\Jon Biavati\AppData\Local\Temp\4\RtmpCMMfgV\downloaded_packages’


- Session info --------------------------------------------------------
 setting  value                       
 version  R version 3.6.2 (2019-12-12)
 os       Windows Server 2012 R2 x64  
 system   x86_64, mingw32             
 ui       RStudio                     
 language (EN)                        
 collate  English_United States.1252  
 ctype    English_United States.1252  
 tz       America/New_York            
 date     2020-01-21                  

- Packages ------------------------------------------------------------
 package     * version  date       lib source        
 assertthat    0.2.1    2019-03-21 [1] CRAN (R 3.6.2)
 backports     1.1.5    2019-10-02 [1] CRAN (R 3.6.1)
 bit           1.1-15.1 2020-01-14 [1] CRAN (R 3.6.2)
 bit64         0.9-7    2017-05-08 [1] CRAN (R 3.6.0)
 callr         3.4.0    2019-12-09 [1] CRAN (R 3.6.2)
 cli           2.0.1    2020-01-08 [1] CRAN (R 3.6.2)
 crayon        1.3.4    2017-09-16 [1] CRAN (R 3.6.2)
 DBI           1.1.0    2019-12-15 [1] CRAN (R 3.6.2)
 desc          1.2.0    2018-05-01 [1] CRAN (R 3.6.2)
 devtools      2.2.1    2019-09-24 [1] CRAN (R 3.6.2)
 digest        0.6.23   2019-11-23 [1] CRAN (R 3.6.2)
 ellipsis      0.3.0    2019-09-20 [1] CRAN (R 3.6.2)
 fansi         0.4.1    2020-01-08 [1] CRAN (R 3.6.2)
 fs            1.3.1    2019-05-06 [1] CRAN (R 3.6.2)
 glue          1.3.1    2019-03-12 [1] CRAN (R 3.6.2)
 magrittr      1.5      2014-11-22 [1] CRAN (R 3.6.2)
 memoise       1.1.0    2017-04-21 [1] CRAN (R 3.6.2)
 pkgbuild      1.0.6    2019-10-09 [1] CRAN (R 3.6.2)
 pkgload       1.0.2    2018-10-29 [1] CRAN (R 3.6.2)
 prettyunits   1.1.0    2020-01-09 [1] CRAN (R 3.6.2)
 processx      3.4.1    2019-07-18 [1] CRAN (R 3.6.2)
 ps            1.3.0    2018-12-21 [1] CRAN (R 3.6.2)
 R6            2.4.1    2019-11-12 [1] CRAN (R 3.6.2)
 Rcpp          1.0.3    2019-11-08 [1] CRAN (R 3.6.2)
 remotes       2.1.0    2019-06-24 [1] CRAN (R 3.6.2)
 rlang         0.4.2    2019-11-23 [1] CRAN (R 3.6.2)
 rprojroot     1.3-2    2018-01-03 [1] CRAN (R 3.6.2)
 rstudioapi    0.10     2019-03-19 [1] CRAN (R 3.6.2)
 sessioninfo   1.1.1    2018-11-05 [1] CRAN (R 3.6.2)
 testthat      2.3.1    2019-12-01 [1] CRAN (R 3.6.2)
 usethis       1.5.1    2019-07-04 [1] CRAN (R 3.6.2)
 withr         2.1.2    2018-03-15 [1] CRAN (R 3.6.2)

[1] D:/Users/Jon Biavati/Documents/R/win-library/3.6
[2] C:/Program Files/R/R-3.6.2/library

R is having problems with the empty space in your windows user name, you could change it, or install to the system level library C:\\Program Files\\R\\R-3.6.2\\library

This raises several questions and does not solve the problem:

  • The error is about the place it downloaded the file to, which I don't have any control over, not the library I'm installing to (because if I specify a different location for the library I get the same error).
  • Doesn't the system library also have a space in "Program Files"?
  • The space in my profile hasn't bothered the 15 or so other libraries I've loaded without any problem.
  • I've tried this in a different installation of R Studio (on another machine) which has the exact same profile name and the library loads just fine.

What can I tell you? this is a know odd behavior of R, some times it happens, some times it won't, I don't know why, but many people here have reported solving their issue by installing into the system-level library.

install.packages("blob", lib = "C:\\Program Files\\R\\R-3.6.2\\library")

I appreciate the help but unfortunately that causes the same error. I verified that I have appropriate permissions to the Program Files directory by using remove.packages() on some of my other packages and reloading them into the system library. All of them installed correctly, except blob.

The issue here is the space in your user account not with Program Files - this is where it splits, in the download path.

Related question with this indeed know issue. It has been solved for the user there:

You can also try remotes::install_cran to see if it uses the same mechanism and error the same.

Here is a blog post about this issue:

This is a known issue with users that have space in the account name. not good for R.

Changing the temp folder to point to a path with no space in it can help with that as it is where the packages files are downloaded. see ?tempdir help page to see how to do it.

Hope it helps.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.