Error Message for GLR

In RStudio:

You should not have a comma after the c in

labels = c,("Bad_Risk", ...


labels = c("Bad_Risk", ...

ty! That fixed it! I tried recoding in: regular R, Anaconda, and databricks...

Now I have a new issue:

If your data are in a data frame, you have to give glm() the name of that data frame. If all of the data are in a data frame named Loans, you can use something like the following. I did not include all of the variables, just to save typing.

glm(formula = yngoodrisk ~ Line.of.Credit + Credit.Score + Monthly.Income, family = binomial(), data = Loans)

Thanks for the reply. I have two files: Loans and Applicants with Loans.csv as training data for good versus bad risk within Applicants.csv. This is to predict the binary outcome via logistic regression.

Does the Loans data set have all of the variables needed to calculate the training fit or do you need to combine Loans and Applicants to construct a data set for training the model? Please explain the structure of each data set.

I finally got it to work; ty for your help, FJCC!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.