Error opening RStudio - "LoadLibrary failed with Error 87: The parameter is incorrect"

Hello - I am a new user and I just installed R followed by RStudio (Windows 10) and I am unable to open RStudio. I get this error listed in the subject-line of this message. Any advice?

Thanks,
Kannan

A quick Google search seems to indicate that this error is related to incorrect installation of AMD graphics drivers and is not specific to RStudio.

This thread suggests a possible solution. You could also try updating your drivers if that doesn't work.

Hi, welcome!

Have you tried changing to software rendering?, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".

Hello, I just joined to post about the same issue.

I have already tried the driver stuff to no avail. I will try the software rendering.

The thing that's different than the OP is that it only happens when I connect to my machine (Win 10 with AMD drivers) remotely using MS Remote Desktop. If I'm just at my computer normally it has no trouble opening up a new instance. So I currently have to make sure it's open at work so when I remotely connect I can still use it, i.e. if the computer needs to restart or anything I need to go back to work just to open it again!

I can change rendering using the global options menu (but this didn't resolve the issue), however I can't get this menu to pop up when I hold control and click on RStudio from the application menu. Is this different than the global options route?

Nope, this is meant to be used in cases where RStudio is not responsive, so you can't access the menus.

Okay. Do you have any other suggestions? There were a few other options that could be selected under the rendering menu.

Why would this only happen when I connect to my machine remotely? And I can use the program fine if the instance was already open when I connected.

I am not able to do the Ctrl while opening R Studio when connected remotely. I just get the same error. But my settings are on software and I'm still having the same problem.

I just had this problem logging in to my desktop remotely from my laptop. Uninstalling my AMD video card driver (in Device Manager on the desktop computer) and restarting it (the desktop computer) seems to have solved the problem :slight_smile:

Hope that helps someone else!