Error : package or namespace load failed for a function (Rhisat2)

Hi guys,

I'm new to R and Bioconductor. This is my first project, I've been trying to use Bioconductor - RSamtools and Rhisat2 packages. At first, I had a recent version of R(4.0.2) but I had to come down to 4.0.0 to use Biocmanager. I installed both the packages and when I ran -> library(Rsamtools), it worked, but when I ran -> library(Rhisat2), it gave me an error that says,

Error: package or namespace load failed for ‘Rhisat2’ in inDL(x, as.logical(local), as.logical(now), ...):

The procedure entry point EXTPTR_PTR could not be located in the dynamic link library.

Although both the packages are in the same path. Looking forward to your inputs, guys.

Thanks in advance.


indicates a configuration issue

Thanks! It worked on the recent version of R. I also think that it throwed the error because I didn't have admin rights.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.