Error reading package library(lessR)


I am trying to use lessR package to reverse code items, but receive an error upon reading the package. It installs fine but when I run library() it won't load. Can someone please help me figure out how to navigate this issue? This is vital for a class assignment.

trying URL ''
Content type 'application/x-gzip' length 3490349 bytes (3.3 MB)
downloaded 3.3 MB
The downloaded binary packages are in
Error: package or namespace load failed for ‘lessR’ in dyn.load(file, DLLpath = DLLpath, ...):
unable to load shared object '/Library/Frameworks/R.framework/Versions/4.0/Resources/library/Rcpp/libs/':
dlopen(/Library/Frameworks/R.framework/Versions/4.0/Resources/library/Rcpp/libs/, 6): Symbol not found: _EXTPTR_PTR
Referenced from: /Library/Frameworks/R.framework/Versions/4.0/Resources/library/Rcpp/libs/
Expected in: /Library/Frameworks/R.framework/Resources/lib/libR.dylib
in /Library/Frameworks/R.framework/Versions/4.0/Resources/library/Rcpp/libs/
In addition: Warning message:
package ‘lessR’ was built under R version 4.0.2

The output you are showing indicates that the package doesn't install fine, you are having issues with a package dependency, accordingly to this GitHub issue, it seems there is an issue with the CRAN version of Rcpp for MacOS systems, Can you try reinstalling it this way?

install.packages("Rcpp", repos="")

Thank you so much!!! I'm so happy that worked

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.