Error trying URL when installing package

Error Information:

Description of issue - Attempting to install package ClincalTrials and Econometrics

Steps taken so far - Ensured up to date version of R

System Information:

  • RStudio Edition: (Desktop or Server)
  • RStudio Version:
  • OS Version:
  • R Version: R 3.5.2 GUI 1.70 El Capitan build (7612)


  • RStudio diagnostics report:
  • Your sessionInfo():
  • RStudio crash report:
  • RStudio application log files:

From Troubleshooting Guide: Using RStudio

I am currently a student attempting to use R for the first time. I have to load a package and chose to add ClincalTrials and Econometrics, but it will not install the package and says trying URL over and over.

The downloaded binary packages are in

Warning: dependencies ‘graph’, ‘Rgraphviz’ are not available
also installing the dependencies ‘ellipsis’, ‘clipr’, ‘rematch’, ‘sys’, ‘forcats’, ‘readr’, ‘cellranger’, ‘gtools’, ‘labeling’, ‘munsell’, ‘backports’, ‘formatR’, ‘utf8’, ‘RJSONIO’, ‘png’, ‘rjson’, ‘rgdal’, ‘rappdirs’, ‘uuid’, ‘e1071’, ‘askpass’, ‘gsl’, ‘ADGofTest’, ‘stabledist’, ‘pcaPP’, ‘DEoptimR’, ‘haven’, ‘curl’, ‘readxl’, ‘fda’, ‘gdata’, ‘XML’, ‘tis’, ‘jpeg’, ‘TeachingDemos’, ‘stringi’, ‘digest’, ‘lazyeval’, ‘rlang’, ‘scales’, ‘viridisLite’, ‘withr’, ‘RColorBrewer’, ‘checkmate’, ‘htmlwidgets’, ‘rstudioapi’, ‘gmp’, ‘polynom’, ‘bibtex’, ‘gbRd’, ‘ellipse’, ‘evaluate’, ‘highr’, ‘markdown’, ‘yaml’, ‘xfun’, ‘hms’, ‘prettyunits’, ‘R6’, ‘crayon’, ‘useful’, ‘dygraphs’, ‘purrr’, ‘bitops’, ‘zip’, ‘lambda.r’, ‘futile.options’, ‘cli’, ‘fansi’, ‘pillar’, ‘pkgconfig’, ‘snow’, ‘hexbin’, ‘crosstalk’, ‘promises’, ‘httpuv’, ‘mime’, ‘sourcetools’, ‘later’, ‘R.oo’, ‘R.methodsS3’, ‘’, ‘glue’, ‘acs’, ‘WDI’, ‘ggmap’, ‘RgoogleMaps’, ‘tigris’, ‘xml2’, ‘selectr’, ‘arm’, ‘igraph’, ‘classInt’, ‘DBI’, ‘units’, ‘reshape’, ‘Jmisc’, ‘dotCall64’, ‘deSolve’, ‘TTR’, ‘openssl’, ‘tidyselect’, ‘assertthat’, ‘BH’, ‘plogr’, ‘Matching’, ‘Formula’, ‘gWidgets’, ‘copula’, ‘Rcpp’, ‘RcppArmadillo’, ‘flexmix’, ‘modeltools’, ‘leaps’, ‘robustbase’, ‘inline’, ‘rrcov’, ‘profileModel’, ‘carData’, ‘abind’, ‘pbkrtest’, ‘maptools’, ‘rio’, ‘maxLik’, ‘glmmML’, ‘miscTools’, ‘scoringRules’, ‘Ecfun’, ‘colorspace’, ‘survey’, ‘estimability’, ‘fracdiff’, ‘ggplot2’, ‘magrittr’, ‘timeDate’, ‘moments’, ‘foreach’, ‘’, ‘gamlss.dist’, ‘plotrix’, ‘msm’, ‘truncnorm’, ‘diagonals’, ‘latticeExtra’, ‘acepack’, ‘gtable’, ‘gridExtra’, ‘data.table’, ‘htmlTable’, ‘viridis’, ‘htmltools’, ‘base64enc’, ‘sets’, ‘mnormt’, ‘pbivnorm’, ‘numDeriv’, ‘xtable’, ‘rpanel’, ‘minqa’, ‘nloptr’, ‘RcppEigen’, ‘prediction’, ‘RcppProgress’, ‘rJava’, ‘lpSolve’, ‘partitions’, ‘minpack.lm’, ‘DEoptim’, ‘optimx’, ‘statmod’, ‘Rdpack’, ‘mvtnorm’, ‘CompQuadForm’, ‘cubature’, ‘quadprog’, ‘coda’, ‘mcmc’, ‘mcmcse’, ‘ucminf’, ‘knitr’, ‘progress’, ‘matrixcalc’, ‘texreg’, ‘reshape2’, ‘MCMCpack’, ‘coefplot’, ‘papeR’, ‘pspline’, ‘bdsmatrix’, ‘RCurl’, ‘SAScii’, ‘openxlsx’, ‘futile.logger’, ‘tibble’, ‘snowfall’, ‘plotly’, ‘MatrixModels’, ‘shiny’, ‘R.utils’, ‘locpol’, ‘corpcor’, ‘polspline’, ‘multcomp’, ‘stringr’, ‘choroplethr’, ‘rvest’, ‘mi’, ‘magic’, ‘trust’, ‘CDVine’, ‘matrixStats’, ‘doParallel’, ‘iterators’, ‘tmvtnorm’, ‘sp’, ‘spData’, ‘sf’, ‘LearnBayes’, ‘deldir’, ‘gmodels’, ‘expm’, ‘ezsim’, ‘ibdreg’, ‘spam’, ‘tseriesChaos’, ‘quantmod’, ‘GPArotation’, ‘dse’, ‘EvalEst’, ‘setRNG’, ‘tframe’, ‘tfplot’, ‘httr’, ‘jsonlite’, ‘tidyr’, ‘Amelia’, ‘dplyr’, ‘MatchIt’, ‘plyr’

  There are binary versions available but the source versions are later:
             binary    source needs_compilation
forcats       0.3.0     0.4.0             FALSE
prediction             FALSE
optimx     2013.8.7 2018-7.10             FALSE
knitr          1.20      1.21             FALSE
plotly        4.7.1     4.8.0             FALSE

trying URL ''
Content type 'application/x-gzip' length 17724 bytes (17 KB)
downloaded 17 KB

trying URL ''
Content type 'application/x-gzip' length 38512 bytes (37 KB)
downloaded 37 KB

trying URL ''
Content type 'application/x-gzip' length 12397 bytes (12 KB)
downloaded 12 KB

trying URL ''
Content type 'application/x-gzip' length 68633 bytes (67 KB)

What can I do to fix this issue? I greatly appreciate any time and help in this matter. Thank you!

It looks like you are trying to load every package in the ClincalTrials and Econometrics taskviews and

There are dozens of packages in each of these groups (each with other packages as dependencies), is that really what you're trying to do?

Usually, folks will install and use only the packages they are actually making use of.

In your console message, I think those are messages for the download of each individual package.



Thank you for your response. As it is for a class, we were asked to choose a random package. I went ahead and tried a different package and it worked. I didn't realize the packages were so large. I appreciate your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.