Error updating SqlRender

I have just tried to update my copy of the SqlRender package on my work desktop. The error was as follows:

Error: .onLoad failed in loadNamespace() for 'rJava', details:
call: inDL(x, as.logical(local), as.logical(now), ...)
error: unable to load shared object 'C:/Users/hunsickerl/documents/Home/R/win-library/3.6/rJava/libs/x64/rJava.dll':
LoadLibrary failure: The specified module could not be found.
Execution halted

I am puzzled, as the rJava.dll file exists exactly where listed. The rJava.dll file is the same size as on my home computer, where the update worked without any error. The version of rJava on the two machines is the same on the two computers. Both computers run Windows 10 updated, and both run the same versions of R (3.6.3) and RStudio (1.2.5033).

Thanks in advance to anyone that can explain the failure of R to be able to find the file that is clearly there, or any advice on how I can complete my update of the SqlRender package
Larry Hunsicker

This is happening because R is not been able to find your Java installation, you can manually set the location adding something like this to your file (you have to change the path accordingly with your actual java version).

Sys.setenv('JAVA_HOME'="C:/Program Files/Java/jdk-11.0.1/")

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.