Error when loading package 'eemeans'

Error Information:

Warning in install.packages :
package ‘eemeans’ is not available (for R version 3.4.4)

Description of issue -

I am unable to load the eemeans package.

Steps taken so far -

  • I've updated to the latest version of R studio (3.4.4)
  • I have tried explicitly setting the repo, e.g; install.packages('eemeans', repo = "")
  • I've tried installing 'mvtnorm' prior, but this package was also 'not available'
  • I've tried selecting all possible repositories using setRepositories(), but still get the same error message

System Information:

  • RStudio Version: Version 1.3.1093
  • OS Version: macOS Mojave v 10.14.6
  • R Version: 3.4.4

The latest version of R is 4.0.3 (RStudio preview build is 1.4.*).

The package requires R >= 3.5.o, so you'll need to update your version of R.

You are confusing your R version with your RStudio version. RStudio is an IDE (Integrated Development Environment) for the R programming language, but they can have independent versions.

eemeans requires R >= 3.5.0 so you have to update R first, the latest stable version is 4.0.2 and you can download it from here

I agree with what's been said about updating R, but in addition it looks like maybe you meant to load emmeans, not eemeans? Apologies if there's also an eemeans package I don't know about.

1 Like

Yeah you're correct, I meant to type emmeans. Thank you


Updated R to 4.0.2 and I can now load the required package. Thank you all for the help.

As a bonus advice, after updating R you have to update your packages with checkBuilt = TRUE


Oh cool, thanks for that!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.