ggplot and R 3.6.3

Just a quick note that it would be valuable to make it more clear/obvious that ggplot2 is not compatible with R 3.6.3. I upgraded R and R studio, and lost ggplot function. I installed tidyverse and then separately, ggplot2, which all seemed to go well. But, only on the installation of ggplot2 did I see a comment about lack compatibility with 3.6.3.

Hi @revolve: Just make clear, you're writing to a community of R and RStudio users here, most of whom are not involved in developing either.

What you likely experienced is that when you upgrade R, you lose access to previous packages you had (like ggplot2), so you have to take steps to regain access. This can be done either by re-installing the packages, or by manually moving the packages to a new location, something I'll leave for others to advise on.

When a package you install has been built using a different version of R than your version, you may see a warning alerting you to that fact, so that you can update either R or the package as needed. This doesn't mean there's necessarily an incompatibility, although if the two versions of R are far enough apart in time, that could be the case.

I hope that helps.

Not the case, what do you base on to make that claim? Here is a proof that it works perfectly fine.


#> [1] "R version 3.6.3 (2020-02-29)"

ggplot(iris, aes(x = Sepal.Length, y = Sepal.Width)) +

Created on 2020-03-27 by the reprex package (v0.3.0.9001)

1 Like

Reinstalled R3.6.3 and Rstudio 1.2.5033, that seemed to go well. Gave up on installing tidyverse as it seemed to run into problems, and just installed ggplot2. I did this in R.

install.packages("ggplot2", dependencies = TRUE)

Re-opening a saved project, I don't get the error I had previously but when I try to view plots, I get this error:

Error: ScalesList was built with an incompatible version of ggproto.
Please reinstall the package that provides this extension.
Run rlang::last_error() to see where the error occurred.

So I ran the rlang command, with the following results.

Any suggestions?

ScalesList was built with an incompatible version of ggproto.
Please reinstall the package that provides this extension.

  1. (function (x, ...) ...
  2. ggplot2:::print.ggplot(x)
  3. ggplot2:::ggplot_build.ggplot(x)
  4. ggplot2:::plot_clone(plot)
  5. ggplot2:::$.ggproto(plot$scales, "clone")
  6. ggplot2:::fetch_ggproto(x, name)
    Run rlang::last_trace() to see the full context.

tried to view Plot2 but this command gives an empty window. Other view commands, e.g. for datasets work fine.


Could you post the output from sessionInfo() here, between a pair of triple backticks -- ``` -- like this?

<--- paste output here, and include ```s

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.