Git in RStudio does not recognize path in UNC format

git

#1

I have a RStudio (ver 1.1.414) project in a server whose path is of the UNC form
//server/path/project

I would like to create a git path to this path and use it via RStudio.

However, if a create a git repository via Tools->Project Options->Git/SVN->Version control system: git, the repository does not point to the above server path, but to Windows 7 path C:\Windows (!). I even accidentally created git repository to C:\Windows, but removed it.

Interestingly enough, if I try to do from RStudio Git -> (cogwheel icon) Settings -> Shell…, it goes to correct project path. But even if I did git init from the shell, RStudio did not change its git path from C:\Windows\ to the correct project path.

Seems like the path is correct for the commands behind the git (cogwheel) settings menu, because invoking Ignore command created file .gitignore into the correct project path.
But behind the Git menu, all the paths point to the wrong path.

The problem was first observed with RStudio version 1.0.153, but same problem was also in version 1.1.414: Tools->Project Options->Git/SVN->Version control system: git created repository to C:\Windows.

The same problem (with images) is described in StackOverflow.


#2

Is mapping that UNC path to a local drive an option for you? This is a common and usually effective workaround to the kinds of issues that arise when using UNC paths directly.


#3

Mapping UNC path to a local drive sounds like a workaround.

Best solution would be of course to fix the use of UNC paths for next RStudio version. I hope to have produced a reproducible error case?


#4

This issue has been brought up before. I'm using drive mapping as a work around and that works. But git is already a complication and it would make the road a wee bit smoother if UNC path worked when using Git within the IDE. (I say this as a novice GitHub user hoping to encourage others in my office to start using Git.)