Help: How to fix R Studio to stop pressing Space Bar to complete each word?

I am using R Studio 1.2.5042 on Mac OS. As I type each word out into the Script section, I have to press Space Bar or Tab at the end of each word to finish that word and move onto the next. As I type each word, R Script only displays the first letter of whatever it is I am typing. This is a very annoying problem for me because I can't really see what I'm typing and having to press Space Bar too many times.

Did anyone encounter the same issue and have found a fix?

Hi @luantpnguyen,
Welcome to the RStudio Community Forum.

Sounds like you are describing the "code completion" behaviour of RStudio. This can be changed to suit your way of working by going through to this RStudio menu item:
Tools > Global Options > Code > Completion.

HTH

I'd probably try turning OFF auto-completion first - and then see if that behavior is what you want.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Thanks. What specifically should I change in the Completion tab to fix this issue?

I tried to turn auto-completion off but the problem remains.