How can I do with ExpiredTokenException error?

Who can help me?
When I upload my app to, an error occurred:

Unhandled Exception: Child Task 1198734634 error: Unhandled Exception: An error occurred (ExpiredTokenException) when calling the AssumeRoleWithWebIdentity operation: Token expired: current date/time 1659684957 must be before the expiration date/time16596

I deleted my token, and add a new one , but it did not work.

1 Like

I have the same error and somebody else 20 minutes ago as well ( Error when Deploying??? - shiny / - RStudio Community). Looks like something is wrong at the servers.

At least i am not alone facing the same issue.

I have reached out to the support team via mail. Since we are all separate users with the same issue in the same timespan, I am expecting we cannot fix this ourselves.


I'm also having the exact same problem this morning. Initially on an app I was struggling to publish anyway so I was assuming it was related to that, but I've now tested multiple apps that previously published without issue and they're all getting the same error.

I'm also facing exactly the same error here. App is running but I cannot deploy, also my dashboard does not load correctly?

Me too, new problem today. I thought I was going crazy until I found this thread!

Thanks for posting this. I'm in the same boat. Saved me time in troubleshooting. I guess we wait and try again later?

I have a reply from RStudio Support. They aware of the issue and working on it.

Live incident link: RStudio Status


Nice job @jbertels !

Do you know if everyone in the world has this problem?

somebody tryed delete and create a new token?

1 Like

I do not know whether everyone has this problem. Original poster had deleted his token and added a new one, which he reported did not work.

1 Like

Hello all! Thank you for raising this issue. The engineers are looking into it and have posted an incident on our status page:
Apologies for the difficulties.

1 Like

I set up a new account (needed to anyway), new token, and the problem persists.

1 Like

Just a note to say that the issue is still in work, but the status page was updated and you can continue to follow status there:


I tried this multiple times! :grimacing:

I'm facing the same issue.