How do I prevent Rstudio Server from _ever_ backing up and restoring my session?

My sessions often die because I run out of memory or disk space, or whatever.

This is fine. What's not fine is that RStudio constantly tries to back up my session and restore it. This can be several gigabytes of memory and takes forever, and is a constant interruption. How can I turn off session-back up and restoration, forever?

I already have this setting:

image

Are you using RStudio Server? If so, you can turn this off by setting the session timeout to 0 as documented here:

https://docs.rstudio.com/ide/server-pro/r-sessions.html#session-timeout

2 Likes

Amazing. So even if I terminate the session, it won't try to restore anything? It'll just restart clean?

@jonathan this did not appear to work for me just now...

I had an R session crash unexpectedly (normal for me) and ...

image

Hi @jonathan I'm curious if you have any additional thoughts here? I haven't been able to get it to stop restoring my session (a 10 minute + delay) if the session crashes.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.