How to update miniconda from RStudio on Windows 10?

Dear RStudio gurus,

What is the best way to update conda when using RStudio on a Windows 10 machine?
I had some issues with following instructions about installing packages etc. in the Windows environment, so I was told by someone in RStudio to do everything related to managing the Python environment from inside RStudio.

I got this message:
==> WARNING: A newer version of conda exists. <==
current version: 4.8.1
latest version: 4.8.2

Please update conda by running

$ conda update -n base -c defaults conda

So I tried

> knitr::opts_chunk$set(echo = TRUE, error = TRUE)
> library(knitr)
> library(reticulate)
> conda_version(conda = "auto")
[1] "conda 4.8.1"
> install_miniconda()
Error: Miniconda is already installed at "C:/Users/userXYZ/AppData/Local/r-miniconda"

I also went to the Terminal window in RStudio and tried this:

C:\Users\userXYZ>conda update -n base -c defaults conda
'conda' is not recognized as an internal or external command,
operable program or batch file.

I think I figured it out. Just in case, posting the answer here fore newbies like myself.

I installed Anaconda. When I opened Anaconda I saw that it has 3 environments:


I found conda 4.8.1 by searching for updatable packages in R-MINI~1 After I updated it (via the Anaconda GUI interface) I am getting (in R)

conda_version(conda = "auto")
[1] "conda 4.8.2"

[1] "conda 4.8.2"

I think I am set.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.