I need help installing a package "DESeq2" having BiocManager issues

Hi R community,

I am new to R and have been having issues installing the "DESeq2" package that I need to do a particular data transformation. I have tried many things and I would like help. I've tried posting in the BioConducter blogs but I am out of messages for the day. Essentially, I seem to be having problems with installing "GenomeInfoDbData" and get stuck at a non-zero exit status. I've been reading some of the posts here and from my understanding I should be able to install from a source that does not need compilation to get access to an older version of the package but it still reports a non-zero exit status. Can you please help me? I've been stuck on this problem for a long time. ):

The downloaded source packages are in
Warning messages:
1: In install.packages(...) :
installation of package ‘GenomeInfoDbData’ had non-zero exit status
2: In install.packages(...) :
installation of package ‘backports’ had non-zero exit status



You will be offered a choice to install v 1.1,10 from source. Choose Yes. If it fails, required operating system facilities are missing. Try again and choose No.

Following successful installation of backports


will succeed under

#> R version 4.0.2 (2020-06-22)
#> Platform: x86_64-apple-darwin17.0 (64-bit)
#> Running under: macOS Catalina 10.15.6

Hi technocrat,

I appreciate your help! So, I tried doing those things and installed the backports. Should I update my OS to Catalina?

Loading required package: GenomicRanges
Loading required package: GenomeInfoDb
Error: package or namespace load failed for ‘GenomeInfoDb’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
there is no package called ‘GenomeInfoDbData’
Error: package ‘GenomeInfoDb’ could not be loaded
R version 4.0.2 (2020-06-22)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Sierra 10.12.6

indicates another missing dependency to be installed, probably by


macOS, R packages and RStudio should be kept roughly synchronized. It is usually not necessary to be at the latest point release, but problems begin accumuating as one or more installed versions begin lagging by a major release.

In addition, macOS suffers from a default configuration that does not include tools required to compile packages from source, when that is necessary. (Most packages are available in binary form, but not always).

I am facing the same problem. I tried a lot of things, but did not find a solution.

Bioconductor version 3.11 (BiocManager 1.30.10), R 4.0.2 (2020-06-22)
Installing package(s) 'GenomeInfoDbData'

package ‘GenomeInfoDbData’ is available as a source package but not as a binary

Warning message:
package ‘GenomeInfoDbData’ is not available (as a binary package for R version 4.0.2)

Hi Tulip,

I figured out the problem. I was using an out of date operating system for R and it wouldn't install DESeq2 which was my main objective. So, maybe try updating your operating system?


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.