I tried to use the arow library to read some parquet files but snappy not installed

How do I install snappy on my rstudio instance?

I tried

sudo apt-get install libsnappy-dev

but it asks for my password. Is the password the same one I log in to rstudio cloud with?

Users are not allowed to install system dependencies on RStudio Cloud, you can explain here which ones you need and why, and RStudio people will evaluate if it makes sense for them to install them on their servers, but this will take some time.

Also, if you give more detailed information about your issue, someone in the community might be able to give you an alternative solution.

For parquet, i need to read snappy compressed files. that is needed for the {arrow} package.

Hi there, I've made an internal ticket tracking this request. I don't have an estimate for when we will install this package, but I'm happy to provide an update to this thread when its available.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.