installing package 'sf' immediately aborts R session within Rstudio

I have used package 'sf' (simple features) successfully for some time, until my recent update of both R and RStudio to the current versions. Now when I install 'sf' (just install, not yet load), the R session within RStudio immediately aborts. Then I open R by itself, which does not abort, I remove package 'sf' from R, and then I can successfully open and run RStudio... but of course I cannot use 'sf'.

I have tried downloading R and RStudio and re-installing, no such luck. Then upgraded my OS, again no dice. I am running on macOS 11.5.1. Is there something installed with 'sf' or its dependencies that could crash R, but only when running in RStudio?

Any advice much appreciated!

1 Like

I found the solution, which was not obvious because R was aborting before I could see an error. Just needed to update Rcpp: install.packages('Rcpp')

Nice catch. I would be appreciated if you flag this problem as solved !

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.