Installing RStudio Dektop on Ubuntu 20

Hi everyone,
I am trying to install RStudio on Ubuntu 20.
R-base is installed and working (4.1.2)

I then tried to install RStudio following the website: Download RStudio Server for Debian & Ubuntu - RStudio

sudo apt-get install gdebi-core
wget https://download2.rstudio.org/server/bionic/amd64/rstudio-server-2021.09.1-372-amd64.deb
sudo gdebi rstudio-server-2021.09.1-372-amd64.deb

However this does not work. The errors are (translating from Germany):

  • dpkg: Error related to archive rstudio-server-2021.09.1-372-amd64.deb

  • cannot open /usr/lib/rstudio-server/www/rstudio/4032CB57FF3A58D9FCAE4CBA2130587E.cache.js.dpkg-new

  • useradd: user Ā»rstudio-serverĀ« already exists (I tried multiple times)

Has someone experienced something similar or could help me interpret what those errors mean?

Thank you in advance

The desktop version is available from here:
Download the RStudio IDE - RStudio

You have been trying to install the server version.

1 Like

Argh, so obvious, thanks Martin!

Nevertheless, the error persists, at least when installing the .deb version for Ubuntu 18.
I'll try the tar.gz tomorrow when I am more awake, but a quick question to be sure: will these run on Ubuntu 20 as only 18 is indicated?