Issue with installing the "drc" package

Im issue im having is loading my package "drc" into r -cloud. I have r studio on my laptop and it loads the package fine. i keep getting the error "Warning in install.packages :
installation of package ‘drc’ had non-zero exit status"

Ive tried going to an older version of R on the cloud studio and i get the same error

This seems to actually be a problem with a dependency of drc - in particular, attempting to do any of the following results in errors:


In both cases, it ends up being that readr is failing.

  • installing source package ‘readr’ ...
    ** package ‘readr’ successfully unpacked and MD5 sums checked
    ** libs
    g++ -I"/opt/R/3.5.0/lib/R/include" -DNDEBUG -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/Rcpp/include" -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/BH/include" -I/usr/local/include -I. -Ircon -fpic -g -O2 -c Collector.cpp -o Collector.o
    g++: internal compiler error: Killed (program cc1plus)
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <file:///usr/share/doc/gcc-5/README.Bugs> for instructions.
    make: *** [Collector.o] Error 4
    /opt/R/3.5.0/lib/R/etc/Makeconf:168: recipe for target 'Collector.o' failed
    ERROR: compilation failed for package ‘readr’
  • removing ‘/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/readr’
    Warning in install.packages :
    installation of package ‘readr’ had non-zero exit status

Is their any way to fix this issue ? Thats the same code i was getting, I also traced it back to a issue with the readr package as well.

Hi @Zclaxton! Welcome!

Yes, as @wburr noted, the problem here is that readr is failing to install. This is because it requires compilation, and the compiler is exceeding RStudio Cloud's current memory limit (1 GB). The same thing currently happens if you try to install tidyverse, too.

Almost all of the tidyverse packages have pre-built binaries cached to avoid this problem, and readr formerly did. It looks like a new version was released to CRAN (on 2018-11-22) that has not been pre-built and cached by the RStudio Cloud team. Unfortunately, I think anything that depends on the latest version of readr is going to fail to install until a new binary can be cached.

Edited to add:

I tried installing the previous version of readr using remotes::install_version(), but this failed. I'm not quite sure why (I have other RStudio Cloud projects with readr 1.1.1 installed which I think installed from a cached binary), but it seems that Cloud's package proxy system doesn't work this way:

remotes::install_version("readr", version = "1.1.1")
Trying http://package-proxy
Error in download_version_url(package, version, repos, type) : 
  version '1.1.1' is invalid for package 'readr'

OK, here's a workaround. I cloned an existing Cloud project of mine where tidyverse (with readr 1.1.1) was already installed, and installed drc into that project.

Go to the following link and add a copy of the project to your Cloud, and you should be able to work with drc that way until this problem with the new readr gets resolved:

1 Like

Thank you so much ! hopefully they resolve it soon but your work around worked !

1 Like

drc should be installable now:


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.