Issues with packages after updating to R 3.5.0

package-installation

#21

Did you install RTools 3.5

Then run?

remove.packages("data.table")
install.packages("data.table", type = "source",
repos = "http://Rdatatable.github.io/data.table")


#22

I installed 3.5.0 on two machines. The install went fine, but it had to load all my packages again. it missed a few, which are easy to load when it becomes necessary.

Tidyverse is working well.

But data.table does not load. I have tried some of the suggestions I found on SO but nothing has worked yet.

I hope this helps.


#23

I have the exact same problem as described by @prosoitos on a MacOS Sierra. The upgrade to 3.5 was smooth and after making sure the macosxtools were upgraded, I ran into the same issue as described here as I had to reinstall several packages due to these kind of error messages -

Error : package ‘markdown’ was installed by an R version with different internals; it needs to be reinstalled for use with this R version

As of now, I re-installed the most common packages I use. Will follow this thread to see what others say!


#24

I think that's to be expected at this point (e.g. see the post by RevoDavid linked to above)!


#25

Not only some packages needed to reinstall, such as data.table, but also memory issues occurs on mac. With version 3.4.4 I created some R images, which can be open with 3.4.4, but the new version encountered a memory issues! Not enough memory to open !!!


#26

I'm running into the issue installing rlang from github,

devtools::install_github("r-lib/rlang")
Downloading GitHub repo r-lib/rlang@master
from URL https://api.github.com/repos/r-lib/rlang/zipball/master
Installing rlang
"C:/PROGRA~1/R/R-35~1.0/bin/x64/R" --no-site-file --no-environ --no-save
--no-restore --quiet CMD INSTALL
"C:/Users/ozd504/AppData/Local/Temp/Rtmpy4LqCr/devtools3e9ce125af1/r-lib-rlang-1bd3ebe"
--library="C:/Users/ozd504/R/win-library/3.5" --install-tests

  • installing source package 'rlang' ...
    ** libs

*** arch - i386
c:/Rtools/mingw_32/bin/gcc -I"C:/PROGRA~1/R/R-35~1.0/include" -DNDEBUG -I./lib/ -O3 -Wall -std=gnu99 -mtune=generic -c capture.c -o capture.o
c:/Rtools/mingw_32/bin/gcc -I"C:/PROGRA~1/R/R-35~1.0/include" -DNDEBUG -I./lib/ -O3 -Wall -std=gnu99 -mtune=generic -c export.c -o export.o
In file included from export.c:1:0:
export/exported.c: In function 'rlang_cnd_type':
export/exported.c:28:1: warning: control reaches end of non-void function [-Wreturn-type]
}
^
c:/Rtools/mingw_32/bin/gcc -I"C:/PROGRA~1/R/R-35~1.0/include" -DNDEBUG -I./lib/ -O3 -Wall -std=gnu99 -mtune=generic -c internal.c -o internal.o
c:/Rtools/mingw_32/bin/gcc -I"C:/PROGRA~1/R/R-35~1.0/include" -DNDEBUG -I./lib/ -O3 -Wall -std=gnu99 -mtune=generic -c lib.c -o lib.o
In file included from lib.c:8:0:
lib/cnd.c:142:24: fatal error: Rinterface.h: No such file or directory
#include <Rinterface.h>
^
compilation terminated.
make: *** [C:/PROGRA~1/R/R-35~1.0/etc/i386/Makeconf:208: lib.o] Error 1
ERROR: compilation failed for package 'rlang'

  • removing 'C:/Users/ozd504/R/win-library/3.5/rlang'
  • restoring previous 'C:/Users/ozd504/R/win-library/3.5/rlang'
    In R CMD INSTALL
    Installation failed: Command failed (1)

#27

R 3.5 is byte-compiling packages on installation. This is great for speed, but does take a bit more space.


#28

Do you happen to have setwd(...) in your .Rprofile file?


#29

I got it to work by reinstalling R without the i386 files. rlang would install after I installed devtools from github, and I finally got ggplot2 to install from github after removing the i386 architecture, seems there's a build problem with ggplot2 on github right now


Difficulty installing dev version of ggplot2 due to rlang::is_list not being found
Difficulty installing dev version of ggplot2 due to rlang::is_list not being found
#30

The ggplot2 github issue has sent me down a long rabbit hole in the last hour. Glad I'm not the only one.


#31

were you able to get yours working?


#32

No, but I'm wondering if there is a separate or deeper problem going on. rlang won't link to some base functions correctly on installation and that seems to be trickling upwards through other package installations. Might be a directory issue? I'm in over my head at that point.


#33

I had the same problem installing the github version of ggplot2. and then I looked at cran and it seems like ggplot2 on cran was updated a year ago on 2016-12-30.

That means I do need the github version because even the plotly recommends it. but it doesn't work.


#34

After updating to R3.5.0 and the latest RStudio I'm having a similar issue (can't install github ggplot2 or even github tidyverse). I get the issue:

devtools::install_github('tidyverse/tidyverse')
Downloading GitHub repo tidyverse/tidyverse@master
from URL https://api.github.com/repos/tidyverse/tidyverse/zipball/master
Installing tidyverse
"C:/PROGRA~1/R/R-35~1.0/bin/x64/R" --no-site-file --no-environ --no-save --no-restore --quiet CMD INSTALL
"C:/Users/emily_ME/AppData/Local/Temp/RtmpQdeo0I/devtools318460497d12/tidyverse-tidyverse-83f6ec3" --library="C:/Users/emily_ME/OneDrive - Market
Economics Limited/Documents/R/win-library/3.5" --install-tests

  • installing source package 'tidyverse' ...
    ** R
    ** tests
    ** byte-compile and prepare package for lazy loading
    ** help
    *** installing help indices
    converting help for package 'tidyverse'
    finding HTML links ... done
    tidyverse-package html
    tidyverse_conflicts html
    tidyverse_deps html
    tidyverse_logo html
    tidyverse_packages html
    tidyverse_update html
    *** copying figures
    ** building package indices
    ** installing vignettes
    ** testing if installed package can be loaded
    *** arch - i386
    Error: package or namespace load failed for 'tidyverse' in library.dynam(lib, package, package.lib):
    DLL 'rlang' not found: maybe not installed for this architecture?
    Error: loading failed
    Execution halted
    *** arch - x64
    ERROR: loading failed for 'i386'
  • removing 'C:/Users/emily_ME/OneDrive - Market Economics Limited/Documents/R/win-library/3.5/tidyverse'
    In R CMD INSTALL
    Installation failed: Command failed (1)

But rlang installed and loads fine, and it's in the library path that shows when I look at .libPaths()

I tried removing and reinstalling rlang and devtools, and tried using the dev versions of both. None of this is working.

I've also tried with Rtools 3.4 and Rtools 3.5. This is super frustrating as I need the dev version of ggplot2 for geom_sf() and other features.


Difficulty installing dev version of ggplot2 due to rlang::is_list not being found
#35

@emilynz I was in the same boat regarding geom_sf so I tried tmap. Works seamlessly with sf and the API is similiar to ggplot2. So if you need to get something done, this might be a good substitution.


#36

I just reverted to R 3.4.2 which means I am able to use the existing ggplot2 dev version that I already had installed. Interestingly when I tried to update it to the current github version it doesn't work on 3.4.2 either, so I'm wondering if it's an RStudio issue...?

I should probably try to install outside of RStudio, but don't have time until next week or so due to deadlines etc at work.


#37

same with me Now I can't even update in R 3.4.4 version as well. It's like they are trying to update something in ggplot2 which crashes it.

We should wait untill it works on someone's computer.


#38

@emilynz Not an rstudio issue. I can replicate this in and out of R with a vanilla session of R etc.


#39

I was able to install ggplot2 from github in the R vanilla terminal


#40

Hi, I am having similar problems at reinstalling lme4 and ggplot like below:
"""

install.packages('lme4')
Installing package into ‘/home/lsun/R_libs’
(as ‘lib’ is unspecified)
trying URL 'http://cran.cnr.berkeley.edu/src/contrib/lme4_1.1-17.tar.gz'
Content type 'application/x-gzip' length 4103343 bytes (3.9 MB)
==================================================
downloaded 3.9 MB

.Rprofile: Setting cran repositoryn* installing source package ‘lme4’ ...
** package ‘lme4’ successfully unpacked and MD5 sums checked
** libs
g++ -I"/usr/local/lib/R/include" -DNDEBUG -I"/usr/local/lib/R/site-library/Rcpp/include" -I"/home/lsun/R_libs/RcppEigen/include" -I/usr/local/include -DNDEBUG -DEIGEN_DONT_VECTORIZE -fpic -g -O2 -c external.cpp -o external.o
In file included from /usr/local/lib/R/site-library/Rcpp/include/Rcpp.h:77:0,
from /home/lsun/R_libs/RcppEigen/include/RcppEigen.h:26,
from predModule.h:12,
from external.cpp:8:
/usr/local/lib/R/site-library/Rcpp/include/Rcpp/Rmath.h: In function ‘double R::pythag(double, double)’:
/usr/local/lib/R/site-library/Rcpp/include/Rcpp/Rmath.h:222:55: error: ‘::Rf_pythag’ has not been declared
inline double pythag(double a, double b) { return ::Rf_pythag(a, b); }
^
make: *** [external.o] Error 1
ERROR: compilation failed for package ‘lme4’

  • removing ‘/home/lsun/R_libs/lme4’
  • restoring previous ‘/home/lsun/R_libs/lme4’

The downloaded source packages are in
‘/tmp/RtmpRsM9YS/downloaded_packages’
Warning message:
In install.packages("lme4") :
installation of package ‘lme4’ had non-zero exit status
"""

Any idea? Thanks!