My working Debian sid RStudio preview version vanished; cannot reinstall

Hi there.

I use Linux Debian sid, its most uptodate branch. Rarely do I have problems with RStudio installation. However, after a last full-upgrade, carried out yesterday, Mar 26, 2020, my former fully operational RStudio (preview version) stopped working. In fact, it was somehow removed...

To fix this, I downloaded the latest preview version, 1.3.929-amd64.deb, for Ubuntu 18/Debian 10 (64-bit) and tried to install it, via dpkg:

dpkg -i rstudio-1.3.929-amd64.deb

Selecting previously unselected package rstudio.
(Reading database ... 721700 files and directories currently installed.)
Preparing to unpack rstudio-1.3.929-amd64.deb ...
Unpacking rstudio (1.3.929) ...
dpkg: dependency problems prevent configuration of rstudio:
rstudio depends on libclang-dev; however:
Package libclang-dev is not installed.

dpkg: error processing package rstudio (--install):
dependency problems - leaving unconfigured
Processing triggers for mime-support (3.64) ...
Processing triggers for desktop-file-utils (0.24-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for shared-mime-info (1.15-1) ...
Errors were encountered while processing:
rstudio

If I try to install libclang-dev, I get the following:

apt install libclang-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libclang-dev : Depends: libclang-9-dev (>= 9~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If I try installing libclang-9-dev, then I get:

apt install libclang-9-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libclang-9-dev : Depends: libstdc++-8-dev but it is not going to be installed
Depends: libgcc-8-dev but it is not going to be installed
Depends: libobjc-8-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If I try to install libstdc++-8-dev, for instance, I get:

apt install libstdc++-8-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libstdc++-8-dev : Depends: libgcc-8-dev (= 8.4.0-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If I try then to install libgcc-8-dev, I get:

apt install libgcc-8-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgcc-8-dev : Depends: libgcc-s1 (>= 1:8.4.0-2) but 10-20200324-1 is to be installed
E: Unable to correct problems, you have held broken packages.

In fact, when I try to install libgcc-s1, I get:

apt install libgcc-s1
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgcc-s1 is already the newest version (10-20200324-1).


I have looked up several messages and posts here and elsewhere, with no success. Any directions to fix this up????

Thanks in advance.

Could you install the packages via the R app? There were multiple issues with mirrored repositories yesterday, so that may have affected you.

Debian repositories are not related to CRAN repositories by any means.

I think this question it would be better asked on a Debian related forum, at least for the system libraries.

1 Like

I have posted a similar question in the specific forum for my distribution, called siduction, which is based on the sid (unstable) branch of Debian. It looks like there might be some bug on the (Debian) packages related to libclang-dev. I posted here as well because I was not sure what would be the exact source of the problem; in fact, it is not solved yet :frowning:

As far as I know, RStudio only offers support for the stable releases, so the latest supported version is Debian Buster

This is how I got it to work,

download libclang from here and install,
https://packages.ubuntu.com/bionic/amd64/libclang-dev/download

and then proceed with your RStudio.deb installation.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Sorry, I do not use any R app to install RStudio. I just download the .deb package from RStudio Preview - RStudio and then use the Debian package manager, as root, like this:

dpkg -i rstudio-1.3.929-amd64.deb

I do not understand what you mean by "Could you install the packages via the R app?". Again, I was trying to install the RStudio IDE itself.

Thanks anyway.

You error messages look like they're referring to R packages, and since running RStudio requires an R installation, it may be that your RStudio install is interacting with an existing R installation to install packages. Can you run the command R from the command line?

Yes, I am able to run it from the command line and the following displays:

R version 3.6.3 (2020-02-29) -- "Holding the Windsock"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-pc-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

None of the mentioned packages are from R. They are from the Debian Linux operating system itself (libclang-dev, libclang-9-dev, etc).

1 Like

Yes, I noticed that, too, after looking around for information. But I still wonder whether the RStudio installation process is pointing to some of the out-of-sync repositories, particularly since the last error message conflicts with the fact that you already have libgcc-s1 installed.

I might suggest changing the title of your post to "my working Debain RStudio preview version disappeared, can't reinstall", in case the preview might be another potential cause of the issue.

1 Like