namespace ‘htmlwidgets’ 0.9 is being loaded, but >= 1.3 is required

Loading required package: shiny
Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
namespace ‘htmlwidgets’ 0.9 is being loaded, but >= 1.3 is required

Have you tried updating htmlwidgets?

1 Like

@andresrcs is right, you need to update htmlwidget. It seems you have an older version (0.9) compare to the one you shiny version require (>=1.3)

yes, I tried it many times and now I am able to upgrade it along with shiny.
I am unable to display a data table now.
It's showing like this. It's not displaying the data.

DT:: renderDataTable({input$inputfile})

That is a different question, could you ask this on a new topic with a minimal REPRoducible EXample (reprex) of your issue?

Here is a very useful guide about how to make a reprex for a shiny app

1 Like

sure. Thank you. I will ask as a new topic.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.