Not able to load tidyverse, i have succesfuly loaded the package. and i am also using the latest version

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘rlang’ 0.4.5 is already loaded, but >= 0.4.6 is required


I have used your update package did not get any output

If rlang_0.4.7 is not in Session_Info() under other attached packages, try restarting the R session and update.packages)

#> R version 4.0.0 (2020-04-24)
#> Platform: x86_64-pc-linux-gnu (64-bit)
#> Running under: Pop!_OS 20.04 LTS
#> Matrix products: default
#> BLAS:   /usr/lib/x86_64-linux-gnu/blas/
#> LAPACK: /usr/lib/x86_64-linux-gnu/lapack/
#> locale:
#>  [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
#>  [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
#>  [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8   
#>  [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
#>  [9] LC_ADDRESS=C               LC_TELEPHONE=C            
#> attached base packages:
#> [1] stats     graphics  grDevices utils     datasets  methods   base     
#> other attached packages:
#> [1] rlang_0.4.7
#> loaded via a namespace (and not attached):
#>  [1] compiler_4.0.0  magrittr_1.5    tools_4.0.0     htmltools_0.5.0
#>  [5] yaml_2.2.1      stringi_1.4.6   rmarkdown_2.3   highr_0.8      
#>  [9] knitr_1.29      stringr_1.4.0   xfun_0.16       digest_0.6.25  
#> [13] evaluate_0.14

Created on 2020-09-03 by the reprex package (v0.3.0)

What output message you get if you run this command?


I am not getting any output the r just restarts

Error in install.packages : Updating loaded packages

i updated r lang but i have new error

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘vctrs’ 0.2.4 is already loaded, but >= 0.3.0 is required

Lather, rinse, repeat.

You have, tragically, found yourself in dependency hell. The only thing to do is keep installing packages and try again until everything works.


I had a install all the packages tidy verse was dependent on thank you

1 Like

Glad it worked out for you!

I ran into a very similar problem with tidyverse and dplyr (I tried updating dependencies but it started giving me a new error and no longer allowed that either) and what I found to be the fix was updating R and RStudio. This fixed everything. Just to keep in mind for the future!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.