“Not Found” error when deploying to shinyapps.io, whereas app deployed well hours ago, and still does locally

Hello,

I would greatly appreciate any feedback about a ‘Not Found’ error I get when deploying a Flexdashboard Shiny app (‘runtime: shiny’) to the shinyapps.io server. I'm actually having trouble deploying any similar app to shinyapps.io now, whether my own app or a basic example such as this one. The difficult bit is that I don't get any errors in the logs, and the only sign is the printing of 'Not Found' (in bold, at the top left of the screen) on the browser after the erroneous deployment has completed.

Local deployment is perfect, and moreover the same app was successfully deployed to shinyapps.io just a few hours ago.

I have updated all programs and packages. Also, my server hours are still fine, so I can't find any reason. I encountered plenty of different errors before, but never this one.

Thank you very much in advance

1 Like

Just to add more information - I also observed the same thing this morning. I've seen that this message appears relative to Rmd (html + shiny) apps and not the "ui.R + server.R" apps. Additionally, just as @pablobernabeu observed, this error occurs even if I just use the Rstudio default text for a Rmd (html + shiny document).

I put this document (the default from Rstudio) on my shinyapp.io with id: 1542533

Finally, this error also appears on my Department's (I'm a grad student) shiny server - so it probably isn't shinyapps.io specific.

1 Like

Thank you! This is very useful to know.

Updated: On Github, I noticed that the rmarkdown package (essential to Flexdashboard-Shiny apps) had been updated just these days (to v1.18). Therefore, I tried to deploy my app after installing the previous rmarkdown version,

require(devtools); install_version("rmarkdown", version = "1.17", repos = "http://cran.us.r-project.org")

and the error vanished! :fireworks:

For a follow-up from the developers, please see https://github.com/rstudio/rmarkdown/issues/1714.

1 Like

I can confirm this happened in a recent PR in rmarkdown

When you install from the previous commit then deployed, the app works

devtools::install_github("rstudio/rmarkdown@1e0964cb7a690866699fd10b41f42b32ea7f32b3")

But if you install the faulty commit, you get the error after deploy.

This is a bug in Rmarkdown, but I don't know how shinyapps.io is running the dashboard with rmarkdown::run(...)

Will try to investigate from the changes introduce in https://github.com/rstudio/rmarkdown/pull/1703 but it will be easier from someone from the shinyapps team I guess.

2 Likes

Thank you for the confirmation!

@pablobernabeu I think I would live this question opened so that shinyapps team can look at this themselves and not believe this is fixed already. What do you think ?

Sounds perfect!