Permission denied when installing a package

Whenever I install a package on my computer, I receive the following error message.
I am the ADMINISTRATOR and I have indeed full permission to the target folder.
I would be grateful for any help and thank you,

R has troubles with empty spaces in Windows user names. That might be causing your problem. A walk-around solution is to install into the system-level package library instead.

You can change the default library path by setting your R_LIBS_SITE environmental variable on a .Reviron or .Rprofile file

# In .Renviron file you can set it by adding this line
R_LIBS_SITE="C:\\Program Files\\R\\R-4.0.2\\library"

Thank you so much for your response. We tried changing the user name such that it did not include any space character, but it still did not work. This is the first time that I ran into such a problem. I have taught hundreds of students R, but never had such an issue before. Any ideas would be greatly appreciated.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.