Problem in Shiny App whit some 'lang'

I get this message in a shiny app:

Listening on
Warning: Error in isTRUE: object 'lang' not found
[No stack trace available]

I am not sure why. This problem came after I ran:
update.packages(lib.loc = "/data/R-libs/x86_64-pc-linux-gnu-library/3.4/", ask=FALSE, checkBuilt=TRUE)

And I got some error messages.


The object '<name>' not found error usually happens when you have not defined a variable and are then using it in a function. SO try and look through your code and see if there is one called 'lang'. If not, this might be an error within a package you're using and they have to update their code.

#> Error in print(myText): object 'myText' not found

myText = "hello"
#> [1] "hello"

Created on 2022-05-30 by the reprex package (v2.0.1)

Hope this helps,


Thank you for your feedback. The truth is that something so strange is going on. When I move the code to other user in the server and I run it I get the app working just fine. It's incredible strange!



I think this points towards some issue with one of the packages your code is dependent on indeed. Did you try and update all packages the code is using?



Yes, I have already done that. Anyway, I moved the code to other Server. In this new Server I have a newer version of R and the app is working fine.

Thank you very much!

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.