problem with factoextra installation

Hello,

I am not able to install the factoextra package and don't understand why, can someone help me ? I have a mac.

This is the message I get :

Warning in install.packages :
  dependency ‘pbkrtest’ is not available
also installing the dependencies ‘car’, ‘rstatix’, ‘ggpubr’


  There are binary versions available but the source versions are later:
           binary source needs_compilation
car         3.0-7  3.0-8             FALSE
rstatix     0.4.0  0.6.0             FALSE
ggpubr      0.2.5  0.4.0             FALSE
factoextra  1.0.6  1.0.7             FALSE

installing the source packages ‘car’, ‘rstatix’, ‘ggpubr’, ‘factoextra’

trying URL 'https://cran.rstudio.com/src/contrib/car_3.0-8.tar.gz'
Content type 'application/x-gzip' length 499932 bytes (488 KB)
==================================================
downloaded 488 KB

trying URL 'https://cran.rstudio.com/src/contrib/rstatix_0.6.0.tar.gz'
Content type 'application/x-gzip' length 394803 bytes (385 KB)
==================================================
downloaded 385 KB

trying URL 'https://cran.rstudio.com/src/contrib/ggpubr_0.4.0.tar.gz'
Content type 'application/x-gzip' length 2689307 bytes (2.6 MB)
==================================================
downloaded 2.6 MB

trying URL 'https://cran.rstudio.com/src/contrib/factoextra_1.0.7.tar.gz'
Content type 'application/x-gzip' length 1386480 bytes (1.3 MB)
==================================================
downloaded 1.3 MB

ERROR: dependency ‘pbkrtest’ is not available for package ‘car’
* removing ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/car’
Warning in install.packages :
  installation of package ‘car’ had non-zero exit status
ERROR: dependency ‘car’ is not available for package ‘rstatix’
* removing ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/rstatix’
Warning in install.packages :
  installation of package ‘rstatix’ had non-zero exit status
ERROR: dependency ‘rstatix’ is not available for package ‘ggpubr’
* removing ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/ggpubr’
Warning in install.packages :
  installation of package ‘ggpubr’ had non-zero exit status
ERROR: dependency ‘ggpubr’ is not available for package ‘factoextra’
* removing ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/factoextra’
Warning in install.packages :
  installation of package ‘factoextra’ had non-zero exit status

The downloaded source packages are in
	‘/private/var/folders/f5/d63bzxzx08s658gdbm0z0njr0000gn/T/RtmpWOpJTk/downloaded_packages’

Then :

> library(factoextra)
Error in library(factoextra) : there is no package called ‘factoextra’

Thank you !

Hi and welcome! Looks like you're on a old version of R and the pbkrtest package requires R 3.6 or higher. I would recommend updating to the most recent version of R (4.0.2) and retrying the installation. You can install R by clicking on your operating system here: https://cran.r-project.org/

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Curious if you wouldn't mind marking this response as a solution? FAQ: How do I mark a solution?

Oh... Thank you so so much, it actually worked. I forgot such a simple rule. Have a nice day, Kind regards