Problem with using "car" package

I'm having a problem with my "car" package in that it gives me this error message when i try to load:


Error: package or namespace load failed for ‘car’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘zip’

I have the latest version of R . I am using a Mac OS version 10.13.2. Im new to R and these forums so sorry if this is common knowledge or my formatting is wrong. Thanks in advance

Embarrassing. I didn't have xcode installed and figured it out literally minutes after I posted this after struggling for a day. Hope this helps some other person who is not good with computers

1 Like

No it's not embarrassing, I've done it loads. Sometimes it's not until you write out the problem that you end up solving it. I can see it says no package called 'Zip' - I usually check I don't need to upgrade anything and load any additional packages it mentions that I don't have. but you solved it anyway :slight_smile:

Thanks. It worked perfectly on my university library computers but of course when I tried it on my home computer it gave problems :see_no_evil:. It's working now though and thanks for the encouraging reply :grinning:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.