R Error %>% error in magrittr

Received "Error in split_chain(match.call(), env = env) :
could not find function "split_chain" message.
As per online community suggestion, split_chain error is gone after downgrading to magrittr 1.5 from version 2.0.1.
Though split_chain error is fixed, the other packages are not working with version magrittr 1.5 and prompted error message to upgrade to 2.0.1. Any one facing same issue? happened in both R ver 3.6.1 and 4.1.0

Have you tried installing the latest {magrittr} and then loading {tidyverse} after all other packages? I know very little about the cause of the error, but some quick Googling turned up this temporary solution. For a permanent solution you need to figure out which other package is at fault and get the author to fix it.

Uninstalled R, R studio and tried with latest versions, no luck with the same Win 10 PC.
It works on fresh install on another Win 10 machine.

Thanks.. I came through the link you shared too.

Starting in a fresh R session, what packages are you loading (in order) when %>% results in the "split_chain" error?

Uninstalled R 3.6.3, 4.1.0 and 4.1.1, also R Studio (rstudio may not necessarily)
Rename the folders all relate to 'R' .. working directory and program installation folder (here in Windows C:\Program files)

Reinstall 4.1.1, install the tidyverse and dependencies package itself, fixed the errors. No more "split_chain" error.

Assuming somewhere conflicts the packages during R version upgrades. (don't know exactly where .. )

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.