R Markdown new file error

Hi everyone,

I just downloaded RStudio and tried to open a new RMarkdown file, but received the following error:

" Creating R Markdown documents

Required package versions could not be found:

htmltools 0.3.5 is required but 0.3 is available
knitr 1.14 is required but 1.12.3 is available
rprojroot 1.0 is not available
rmarkdown 1.6 is required but 0.9.5 is available

Check that getOption("repos") refers to a CRAN repositiry that contains the needed package versions. "

I ran getOption("repos") and received this output:

[1] TRUE

Also, I downloaded this version of Rstudio: "RStudio 1.1.463 - Mac OS X 10.6+ (64-bit)".

Currently using macOS Mojave version 10.14.3.

Appreciate your help!

1 Like

From the console pane

1 Like

Thank you. I realized that my "R" program, not "RStudio", was not the most recent version 3.5.2. Once I downloaded the new R, I was able to go ahead and update the packages. RMarkdown works now!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.