R Session Aborted when changing file directory

Hi, I am a windows 10 user and I just installed R 4.0.2 and RStudio-1.3.1073. I don't have any code running but I tried to change to a different folder in "File" panel by clicking the folder name. However the error of "R Session Aborted" appears. I tried to reinstall R and R studio, same error persists.

However, when I later reinstalled the older version RStudio-1.2.5042, I dont have this error.

Wondering if anyone encountered similar issue before or could share some advise please.


I had the same experience, run as administrator helped once, then it started again.

Same problem here. As soon as I update to latest version of Rstudio the problem began.
My post:

Any resolution on this issue? R studio is crashing for me when I try to use the files tab. Thanks!

Try creating a new project in an empty folder in the root directory (C:).

This is wild speculation on my part, but the thing which seems most reasonable to me is either in the file path to your working directory or in one of the file names in that directory, you have some kind of non-standard character which is causing R Studio to crash when it attempts to render the pane.

Again, that is just speculation, but the easiest way to start debugging it is to simplify the situation and eliminate as many possible causes as possible.

If it still throws an error when you try to view the contents of an empty folder on the C: drive, it might be some kind of permission issue or possibly some overactive anti-malware pitching a fit about R Studio accessing the filesystem.

Beyond that I'm hesitant to guess.

Could be related to https://github.com/rstudio/rstudio/issues/6701 ?? (which we're trying to fix for 1.4). Are there non-ASCII characters in the path to your project?

1 Like

Suddenly I had the same problem. Changing the folder terminates the session. I did as @elmstedt advised and the problem occurred again. Since there are no files with non-standard names in the C: drive folder, the reason must be different. Unfortunately, I don't know how to solve it and RStudio is useless for me at the moment.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.