R studio crashed while running python by reticulate packages

System details

RStudio Edition : Desktop
RStudio Version : Version 1.3.1093
OS Version      : "Darwin" 
R Version       : "R version 3.6.3 (2020-02-29)"

Steps to reproduce the problem

I run the {r} chunk first:

#mac environment 

And then run the {python} chunk:

# import library
import pandas as pd
import numpy as np
import matplotlib.pyplot as plt
from pylab import *
import matplotlib.colors as colors

The R studio crashed without any other information.

I tried to re-install the package "rcpp" and "reticulate" but it does not work.

I’ve seen others with this error and had one very similar myself. I’m not sure what if anything in particular causes it, but what worked for me was basically starting from scratch.

• uninstalled all previous conda envs and anaconda-navigator, reinstalled
• installed new RStudio, updated R version, and reinstalled all R packages. Would definitely be worth trying the dev version of R studio which has additional Python functionality: RStudio Preview - RStudio
• installed standalone Py 3.8 locally
• installed miniconda via reticulate
• added Py 3.8 to the .bash_profile file

I’ve also seen suggestions that installing the dev version of reticulate from GitHub with dev-tools fixed the errors for some others.

Most of the things I suggested above were things that I tried based on Google searches of this issue rather than any real understanding of what was going on.... I’m not sure I’ve ever been as frustrated or confounded with a bug as I was with this one when I encountered it, so I hope this helps!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.