R Studio session crashes and terminates

I am trying to run an optimization model and it crashes at different points each time. Seems to be related to a package, but not sure which one. I tried but can't find it. What do I do?

The version info is as below:
platform x86_64-w64-mingw32
arch x86_64
os mingw32
system x86_64, mingw32
major 3
minor 6.2
year 2019
month 12
day 12
svn rev 77560
language R
version.string R version 3.6.2 (2019-12-12)
nickname Dark and Stormy Night

The crash log for today is as below. Only tried it once to avoid duplication and noise.
26 Feb 2020 15:47:18 [rsession-] CLIENT EXCEPTION (rsession-): (TypeError) : Cannot read property 'object_types' of null;|||org/rstudio/studio/client/workbench/views/connections/ui/ObjectBrowserModel.java#152::isLeaf|||com/google/gwt/user/cellview/client/CellTreeNodeView.java#112::render|||com/google/gwt/user/cellview/client/CellTreeNodeView.java#198::replaceAllChildren|||com/google/gwt/user/cellview/client/HasDataPresenter.java#1062::resolvePendingState|||com/google/gwt/user/cellview/client/HasDataPresenter.java#981::execute|||com/google/gwt/core/client/impl/SchedulerImpl.java#167::runScheduledTasks|||com/google/gwt/core/client/impl/SchedulerImpl.java#272::flushFinallyCommands|||com/google/gwt/core/client/impl/Impl.java#313::exit|||com/google/gwt/core/client/impl/Impl.java#275::entry0|||rstudio-0.js#-1::eval|||Client-ID: 33e600bb-c1b1-46bf-b562-ab5cba070b0e|||User-Agent: Mozilla/5.0 (Windows NT 10.0 Win64 x64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.1 Chrome/69.0.3497.128 Safari/537.36
26 Feb 2020 15:49:28 [rsession-] WARNING Process supervisor did not terminate within 1 second; LOGGED FROM: void __cdecl `anonymous-namespace'::rCleanup(bool) C:\jenkins\workspace\IDE\windows-v1.2\src\cpp\session\SessionMain.cpp:1193

It looks like you are running the RStudio IDE on a windows machine. Is that correct? Which RStudio version do you have? What happens if you run your R code outside of RStudio?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.