R4: there is no package called ‘unix’

Hi,

I installed (self compiled) R 4.0.3 patched on Ubuntu 20.04 and got an issue installing new packages. R is telling me that there is no package called ‘unix’:

Warning in install.packages :
  installation of package ‘xxx’ had non-zero exit status
Error in loadNamespace(name) : there is no package called ‘unix’
Calls: :: ... loadNamespace -> withRestarts -> withOneRestart -> doWithOneRestart
Execution halted

configure summary:

configure: WARNING: unrecognized options: --enable-jit

R is now configured for x86_64-pc-linux-gnu

  Source directory:            .
  Installation directory:      /usr/local

  C compiler:                  gcc  -g -O2
  Fortran fixed-form compiler: gfortran -fno-optimize-sibling-calls -g -O2

  Default C++ compiler:        g++ -std=gnu++11  -g -O2
  C++14 compiler:              g++ -std=gnu++14  -g -O2
  C++17 compiler:              g++ -std=gnu++17  -g -O2
  C++20 compiler:
  Fortran free-form compiler:  gfortran -fno-optimize-sibling-calls -g -O2
  Obj-C compiler:

  Interfaces supported:        X11, tcltk
  External libraries:          pcre2, readline, curl
  Additional capabilities:     PNG, JPEG, TIFF, NLS, cairo, ICU
  Options enabled:             shared R library, shared BLAS, R profiling

  Capabilities skipped:
  Options not enabled:         memory profiling

  Recommended packages:        yes

Is there something I missed?

Thanks in advance!

Have you tried installing the missing package?

install.packages("unix")

But it did.

Anyway. I deleted my whole rstudio settings/my complete home folder and created a complete new workspace with no libs except the R system libs. Now its working. There is still no package called unix but R does not complain about it.

I dont know what that was.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

That is unlikely, can you post the actual error message? Otherwise we don't have enough information to help you.

Gives exact the same error.

Could it be...

I updated R3.6 to R4. rstudio creates folders like R/x86_64-pc-linux-gnu-library/4.0 to install packages for a user.

I had two folders, 3.6 and 4.0. Maybe it used both instead only one? I already guessed that are R packages from 3.6 are not compatible to R4 but this would be a reason.