RcmdrPlugin.DoE fatal error windows

Hi, when i tried to run the package "RcmdrPlugin.DoE" , the R sessions is aborted, encountered a fatal error and the sessions is terminated.
what I can do?
The log is this:
2022-06-07T22:00:06.695390Z [rsession-cleve] ERROR system error 10053 (An established connection was aborted by the software in your host machine) [request-uri: /help/library/RcmdrPlugin.DoE/html/00Index.html]; OCCURRED AT void __cdecl rstudio::session::HttpConnectionImpl::sendResponse(const class rstudio::core::http::Response &) c:\users\jenkins\workspace-\open-source-pipeline\prairie-trillium\src\cpp\session\http\SessionHttpConnectionImpl.hpp:154; LOGGED FROM: void __cdecl rstudio::session::HttpConnectionImpl::sendResponse(const class rstudio::core::http::Response &) c:\users\jenkins\workspace-\open-source-pipeline\prairie-trillium\src\cpp\session\http\SessionHttpConnectionImpl.hpp:159

Hi @clevertonp,
Welcome to the RStudio Community Forum

First download and install the Rcmdr package and all its dependencies.
Second download and install RcmdrPlugin.DoE and all its dependencies.
Then, start Rcmdr with library(Rcmdr) and then use the Rcmdr pull-down menu to install the DoE plugin. You then have to restart Rcmdr for the design menu items to be available.

Hope this helps.

Hi @DavoWW
Thanks for the response.
I tried to reinstall the Rcmdr package and RcmdrPlugin.Doe.
When I launch the Rcmdr, the program crash again (message: R session aborted, fatal error).

Like in the image bellow

@clevertonp,
Not completely sure what is happening but these are a few things I would try:
Stop loading the .Rdata file at startup to see if this makes a difference.
See if Rcmdr runs in the Rgui.
Check that you are using the latest versions of RStudio and all your other packages.
Try running RStudio with administrator privileges.
HTH

Hi, @DavoWW
I´m new in R studio software, how can run rcmdr with Rgui?
By the way I tried the other options which you mentioned (stop loading .rdata at startup, run with administrator priviligies, install with adm priviligies also) and did not work

Thank you

@clevertonp,
Rgui is the simple graphical user interface that you get when you install R. It should appear as an icon on your desktop or in your start menu. It can be used to run R without involving RStudio.

ah ok, by just usig the Rgui is run perfect now, thank you
is possible to fix this in Rstudio or not needed?

@clevertonp,
Rcmdr will run fine in the Rgui but then you miss out on all the RStudio goodies. I’d try uninstalling and reinstalling RStudio in case it’s corrupted or damaged.

@DavoWW
I tried to reinstall and install again, and this error is the same in three different machines.
For now I can open the application gy Rgui, but could be could to do in the Rstudio.

To save you the reinstalling trouble, Rcmdr is not currently compatible with the latest RStudio version. This compatibility is frequently broken with updates but since Rcmdr is just a graphical interface for using R as a more traditional statistical software rather than a programming language, running it from the R GUI makes no difference in functionality. Although, if I was you, I would invest my time learning to use R directly rather than trough a graphical interface.

1 Like

@andresrcs
thank you for the answer, for me I need this specific package futher the R in order to do Design experiments.
I think it runs well in R Gui without any problem, and after I can export the datas to Rstudio and work there.

Thank you so much

1 Like

I am also having similar a fatal R error when attempting to load Rcmdr in Rstudio ( windows 2022.02.3 Build 492; R version 4.2.0 (2022-04-22 ucrt) ). It loads fine in the RGUI.

I think I have narrowed the problem down to the package tclk2. Loading this package in Rstudio (fresh start, no optional packages loaded) immediately causes a fatal r session error. Any guidance would be appreciated.