Rfast takes too much RAM?

Is it somehow possible to install the package Rfast on RStudio cloud? It seems like there is a problem with running out of memory. The compilation of the package stops at the function rint from the package.

In a new project I was able to install Rfast without issue.
What had you done just prior to attempting to install?
Could you include the full error please?

Prior to the installation I tested some code for speed with profvis. I checked for solutions online and tried to install Rfast. The first time it stopped the compilation at the function design_matrix. After a search online I was under the impression that there is an issue with the provided RAM. I cleaned up the workspace, detached most of the packages, und deleted unnecessary files. Then I tried again and it stopped at a later point, at function rint.

The message I get is:

Installing package into ‘/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5’
(as ‘lib’ is unspecified)
trying URL 'http://package-proxy/src/contrib/Rfast_1.9.2.tar.gz'
Content type 'application/x-gzip' length 326022 bytes (318 KB)
downloaded 318 KB

* installing *source* package ‘Rfast’ ...
** package ‘Rfast’ successfully unpacked and MD5 sums checked
** libs
g++ -std=gnu++11 -I"/opt/R/3.5.0/lib/R/include" -DNDEBUG  -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/Rcpp/include" -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/RcppArmadillo/include" -I/usr/local/include  -fopenmp -fpic  -g -O2 -c Diag.cpp -o Diag.o
g++ -std=gnu++11 -I"/opt/R/3.5.0/lib/R/include" -DNDEBUG  -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/Rcpp/include" -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/RcppArmadillo/include" -I/usr/local/include  -fopenmp -fpic  -g -O2 -c Norm.cpp -o Norm.o
g++ -std=gnu++11 -I"/opt/R/3.5.0/lib/R/include" -DNDEBUG  -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/Rcpp/include" -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/RcppArmadillo/include" -I/usr/local/include  -fopenmp -fpic  -g -O2 -c Rank.cpp -o Rank.o

... this goes on for a while until ...

g++ -std=gnu++11 -I"/opt/R/3.5.0/lib/R/include" -DNDEBUG  -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/Rcpp/include" -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/RcppArmadillo/include" -I/usr/local/include  -fopenmp -fpic  -g -O2 -c rep.cpp -o rep.o
g++ -std=gnu++11 -I"/opt/R/3.5.0/lib/R/include" -DNDEBUG  -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/Rcpp/include" -I"/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/RcppArmadillo/include" -I/usr/local/include  -fopenmp -fpic  -g -O2 -c rint.cpp -o rint.o
g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-5/README.Bugs> for instructions.
make: *** [rint.o] Error 4
/opt/R/3.5.0/lib/R/etc/Makeconf:168: recipe for target 'rint.o' failed
ERROR: compilation failed for package ‘Rfast’
* removing ‘/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.5/Rfast’
Warning in install.packages :
  installation of package ‘Rfast’ had non-zero exit status

The downloaded source packages are in

This is what indicates out out memory.

It isn't clear to me why you get this in a new project while it succeeded for me, but we can add this to the cache of pre-built packages. Try again in about an hour.

Thanks Josh! Still get the same error, however opening a new project and installing Rfast has worked. I switched the files to the new project with the installed Rfast.

If you uninstall and reinstall Rfast in the original project, it ought to work as well.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.