RMarkdown does not knit document: Error: attempt to use zero-length variable name

Hello everyone,

I really need your help. I am writing a paper for university and now i don't manage to knit my document in Rstudio for RMarkdown. I also tried to knit a new empty document and it gives me the same error, so I guess it can't be my code that is wrong.

I just recently updated RStudio with a new Version and downloaded Latex, because before this error it showed me errors that were related to these issues.

Here the error message:
Error: attempt to use zero-length variable name
Execution halted

I will appreciate any help!
Thanks a lot!


could you share an example ? Are you able to knit the default Rmarkdown document you get when you create a new Rmd document ?

To which format are you trying to knit ?

1 Like

Hey, thanks a lot for your reply. Yesterday the problem resolved itself. Before it got solved I was trying to knit a PDF, but nothing worked, neither html or word. Also when I tried a new default Rmarkdown document it did not work.
I didn't change anything in the R settings, time simply passed and in the end it worked again. :thinking:
The error was always this one:
Error: attempt to use zero-length variable name
Execution halted
Would be interesting to know what the problem was, but I am happy it is resolved now.
Thank you for your answer!

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.