Rmarkdown error after updating RStudio Desktop

Hi all,

I've been a user of RStudio with no issues with the Desktop IDE to date: until today. I upgraded my RStudio to the latest version and tried to Preview the example R Notebook whereupon I got this error in the R Markdown tab:

Error: invalid version specification 'find'
In addition: Warning message:
In system(paste(shQuote(path), "--version"), intern = TRUE) :
running command '"C:/PROGRA~3/CHOCOL~1/bin/pandoc.exe" --version' had status 65535
Execution halted

Moreover, the Viewer tab is completely blank. I've looked at other posts on the RStudio Community, Google, and have checked Stack Overflow without any solution. This situation is preventing me from completing a programming assignment and it's driving me nuts. Can anyone help?


READ to the END for Likely Solution
I don't have any specific experience with this issue (very few people likely will), but here is how I would think about the problem. I'll be typing this as I go and just kind of record my progress so you (and others) might get an idea of how you could go about solving problems. WARNING: there will most certainly be dead ends, false starts, and ideas which go nowhere ahead.

First, ask: What changed? You updated R Studio.

Next ask: Did I change anything else? I'm guessing your answer is probably no, but think about it a bit before dismissing it.

Then ask: Is it possible the thing(s) I changed had non-obvious side-effects? Since we're having issues we can't explain and we're asking if something is possible the answer here is almost always yes.

So, the next logical question is to ask: What could those side effects be? For this we'll need to examine what you are doing a little more closely.

  1. You are using an R Notebook
  2. The error happens when you try to preview
  3. The actual command throwing the error is system() so it's happening in the OS, rather than in R.
  4. The error is related to pandoc and it has something to do with getting the version.
  5. The error status is 65535

So, we have to wonder: How does the preview function work with an R Notebook? I, personally, have no idea as I don't work in notebooks, but I know they show results inline in the R Studio application which is the only thing you changed.

So, now we might be getting somewhere. You can try to do other things like see if you can knit to a PDF or html. These use different methods of rendering so if one works and the other doesn't, this might help to inform your path forward.

We might also realize that the pieces responsible for doing the rendering in your notebooks come from packages/other software, rather than base R, so it might be that the newer version of R Studio is expecting a newer version of a package.

We can also Google parts of the error. I tried "status 65535" and error 65535 without specifically concerning myself with it being related to R. It seems to be related in some way to the file system.

Then, Googling "Error: invalid version specification find" led me to what will probably be your solution:

And leads me to think you're using this Chocolatey package manager for Windows which is appparently a thing I have never heard of before... (This would have been useful information to include in your initial report of the problem too.)

Anyway, the answer there was written by Yihui Xie who literally wrote the book on knitr, it will almost certainly be fruitful to take the recommended actions.

And, since we've found a very promising path to start working down, I'll stop here.

Good luck!



Thanks so much for teaching how to go about solving the problem instead of just giving the answer! That stackoverflow thread you sent worked. For others who may have this problem, I'm documenting my steps below:

  1. close RStudio (if already open)
  2. in Windows 10 go to the "Apps and features" control panel and uninstall Pandoc
  3. open a Windows 10 command prompt (in Administrator mode) and type:

choco uninstall pandoc
choco install pandoc

  1. open RStudio
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.