RStudio connect & Python setup problem

apologies in advance but I'm not an expert on python - just sys admin!

I've been asked to get rstudio connect to work with python.

I’ve tried the installation as per the website instructions however these refer to CentOS so I’ve had to amend things a bit as we use Ubuntu.

Python3 was already installed systemwide so I’ve installed a python environment in /opt/python/3.7.7 as per the instructions.

The ubuntu package for libev-devel seems to be python3-libevdev which I have also installed but this probably installed for the default version, which may be the cause of the proble and the version installed in /opt/python may not be seeing it. But not knowing enough about python I'm not sure how to fix this.

I’ve also added python3.7.7 to the path in /etc/profile.d/python.sh

what am i doing wrong?

thanks

You can find our recommended instructions for installing Python at https://docs.rstudio.com/resources/install-python/

This contains instructions for Ubuntu as well - just make sure you click on the correct tab:

That page also has instructions for installing additional python libraries in the correct location:

sudo /opt/python/3.7.7/bin/pip install  ...

I hope this helps.

sorry tried that -
it breaks when I add the python config to rstudio.

[Python]
Enabled = true
Executable = /opt/python/3.7.7/bin/python

This is the version of libevdev installed

apt-cache policy python3-libevdev
python3-libevdev:
Installed: 0.3-1
Candidate: 0.3-1

The instructions I’ve been following are on
docs.rstudio.com/resources/install-python/ & docs.rstudio.com/rsc/integration/python/

error message when adding python to config file is:

● rstudio-connect.service - RStudio Connect
Loaded: loaded (/lib/systemd/system/rstudio-connect.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2020-10-16 12:12:53 BST; 1s ago
Process: 123595 ExecStart=/bin/sh -c exec /opt/rstudio-connect/bin/connect --config /etc/rstudio-connect/rstudio-connect.gcfg >> /var/log/rstudio-connect.log 2>&1 (code
Main PID: 123595 (code=exited, status=1/FAILURE)

Oct 16 12:12:52 azscrsconnect01 systemd[1]: Started RStudio Connect.
Oct 16 12:12:53 azscrsconnect01 systemd[1]: rstudio-connect.service: Main process exited, code=exited, status=1/FAILURE
Oct 16 12:12:53 azscrsconnect01 systemd[1]: rstudio-connect.service: Failed with result 'exit-code'.

It’s probably something simple, but no idea what it is!

think i've found the problem

Was caused by a too new version of Virtualenv

2020/10/16 12:25:39 Using Python package cache bind mount directory: /opt/rstudio-connect/mnt/python-packages

2020/10/16 12:25:39 Using Python environment cache bind mount directory: /opt/rstudio-connect/mnt/python-environments

2020/10/16 12:25:39 Using git repository cache bind mount directory: /opt/rstudio-connect/mnt/git

2020/10/16 12:25:39 Identified 2 CPUs; configuring Server.CompilationConcurrency: 1

2020/10/16 12:25:39 Configuring licensing to use a local license...

2020/10/16 12:25:39 Detected Python version 3.7.7 at /opt/python/3.7.7/bin/python3.7

2020/10/16 12:25:39 Virtualenv version 20.0.35 in python at /opt/python/3.7.7/bin/python3.7 is newer than the maximum required version 19

2020/10/16 12:25:39 To proceed anyway, set LibraryCheckIsFatal = false under the [Python] heading in the configuration.

i've added the "LibraryCheckIsFatal" line to the configuration file and it works now.

Hope it doesn't cause a problem though!