RStudio crashing on start-up

Error Information:

Description of issue - Whenever opening RStudio, the error message "R Session Aborted. R encountered a fatal error. The session was terminated." appears. On clicking "Start New Session", the same error occurs. R in the terminal and GUI still work.

It may also be relevant that I was previously using Microsoft R Open, however had issues with it and was attempting to switch back to CRAN R; my "Current" R version in /Library/Frameworks/R.framework/Versions/ now points back to the CRAN version:

104561mopdt:Versions keason$ ls -lhrt
total 8
drwxrwxr-x  6 root       admin   204B 15 Jan  2016 3.2
drwxrwxr-x  3 root       admin   102B 10 Jun  2016 3.1
drwxrwxr-x  6 root       admin   204B  8 Mar  2017 3.3
drwxrwxr-x  7 root       admin   238B  4 Feb 17:31 3.5.1-MRO
drwxrwxr-x  6 root       admin   204B 26 Feb 18:52 3.5
drwxrwxr-x  3 root       admin   102B 26 Feb 18:52 3.4
lrwxr-xr-x  1 adminkeason  admin     4B 27 Feb 13:19 Current -> 3.5/

CRAN 3.5.2 is the version being accessed by terminal/GUI:

> R.version
platform       x86_64-apple-darwin15.6.0   
arch           x86_64                      
os             darwin15.6.0                
system         x86_64, darwin15.6.0        
major          3                           
minor          5.2                         
year           2018                        
month          12                          
day            20                          
svn rev        75870                       
language       R                           
version.string R version 3.5.2 (2018-12-20)
nickname       Eggshell Igloo  

Attempted steps taken to fix -

  • Uninstalling and reinstalling RStudio
  • Updating all packages
  • Removing startup files, .RData, .Rprofile etc. from home directory
  • Removing ~/.rstudio-desktop

System Information:

From RStudio Desktop Will Not Start on

I have found that RStudio will still open successfully on another (admin) user account. This suggested to me that there might be some environment variable that is causing this error. I unset DYLD_LIBRARY_PATH, CPATH, CUDA_HOMES and CUDA_HOME9 which were not set for the user that RStudio will start as. However this has not resolved the issue.

Any help would be amazing.

I have installed R version 3.4.4 from this page: as I couldn't find 3.4 for Mac on RStudio now opens successfully.

I also tried version 3.5.3 from that page but this still caused RStudio to crash.

Are things any better with the preview release?

Thanks for your reply, but unfortunately not. With both 3.4.4 and 3.5.2 the preview release opens an RStudio window but it is blank with no content inside it. I can see the menus but they are unresponsive.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.