Rstudio Desktop Crashes on Startup with Library not Loaded

Just in case it's useful to others.

Problem: On a MacBook, RStudio crashes on startup with the error "RStudio cannot be opened because of a problem".


  • MacBook Air 2018, macOS 10.14.6
  • Installed R-4.1.2.pkg (R 4.1.2 binary for macOS 10.13 (High Sierra) and higher, Intel 64-bit build)
  • Installed RStudio-2022.02.0-443.dmg

The crash report includes the lines:

  • Termination Reason: DYLD, [0x1] Library missing
  • Library not loaded: @executable_path/../Frameworks/libssl.1.1.dylib


  • RStudio-2022.06.0-daily-156.dmg (Latest daily build) -> Didn't work. Got the same error.
  • RStudio-2021.09.3-385.dmg (Latest patched version of the previous version) -> Didn't work. Got the same error.


  • RStudio-2021.09.2-382.dmg (Two versions back) -> This worked! RStudio Desktop started without crashing.

Thank you so much, it worked for me too!

1 Like

That's great to hear @LiseD , I'm glad it was helpful.

This incident has been reported on github:

In the process of the conversation on github I realised that the OS version I was using when I encountered this issue is no longer supported.
The oldest macOS version supported is 10.5 Catalina.

So, while the solution I described in the post above seems to be a useful workaround, the preferred / supported way to resolve the issue is to upgrade the OS.

Worked for me, as well. Thanks!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.